3

Even though I have no characters selected, TeXstudio 2.8.4 appears to indent the whole line instead of inserting \t at the position my cursor is. This makes it a pain to, for instance, use tabs to align a table's columns.

How can I make the Tab key behave exactly as in typical text editor? (insert \t at the position of the text cursor, not at the beginning of the current line)

  • 2
    In my editor the TAB key does precisely nothing, so that I'm sure to not insert in my file any \t. I believe they're evil. ;-) – egreg Sep 12 '14 at 23:35
  • 2
    The new version indeed binds TAB to “indent selection”. I get a <tab> with Alt-TAB. – egreg Sep 12 '14 at 23:50
  • @egreg Unfortunately, Alt+Tab is the Windows shortcut for switching between windows, so that doesn't work for me. I tried setting the Indent selection hotkey to <none> instead of Tab, but the issue seems to persist (pressing tab inserts tabs at the beginning of the line, not the cursor). By the way, I don't mean anything strange by "inserting \t" - I just want the Tab key to do the same thing in TexStudio as in Notepad. – Superbest Sep 15 '14 at 0:01
3

This appears to be related to a bug in version 2.8.4.

tab is assigned to indentSelection, unfortunately the operation can't be left without a shortcut due to a bug (fixed in repository)

From the relevant bug report. Jan Sundermeyer says the bug will be fixed in the next version.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.