2

I am writing my thesis in the document class scrbook, and have the footnotes counter set to start again from 1 in each chapter. However when I reference a source more than once within a chapter, it cross-references back to the very first occurrence of this source even if this was in a previous chapter, instead of to the first occurrence in the current chapter.

In my MWE the source `Al Bashir' is in a footnote in Chapter 1, and then again in two footnotes in Chapter 2. In Chapter 2 it should give the full citation, and then the following footnote should cross reference this first one in Chapter 2 and NOT refer back to the footnote in Chapter 1.

How do I re-set the cross-referencing counter as well as the footnote counter for each chapter?

My MWE is:

\documentclass[bibliography=totoc,a4paper,openright]{scrbook}

\usepackage[backend=biber, style=oscola, indexing=cite]{biblatex}
\addbibresource{testingbiblio.bib} %necessary for Oscola
\usepackage[style=british]{csquotes} %necessary for Oscola
\usepackage[noautomatic,nonewpage,splitindex]{imakeidx}

\makeatletter   % the commands to ensure footnotes start new numbering at each chapter
\@addtoreset{footnote}{chapter}
\makeatother

\begin{document}

\chapter{First}
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Phasellus eget elit gravida, pharetra mauris at, malesuada dui. Sed vitae tortor ante. Quisque sollicitudin accumsan nulla sit amet mattis.\footcite{Tadic} In eu vulputate sem, in sagittis arcu. Nullam fringilla libero non nisi aliquam, eget pulvinar arcu pulvinar. Ut tristique ullamcorper nisl, vitae cursus nulla varius vel. Proin non rhoncus risus.\footcite{AlBashirIndictment}

\chapter{Second}

Lorem ipsum dolor sit amet, consectetur adipiscing elit.\footcite{Vaillancourt} Proin non rhoncus risus.\footcite{AlBashirIndictment} Phasellus eget elit gravida, pharetra mauris at, malesuada dui.\footcite{AlBashirIndictment}


\end{document}

My bib file is:

@jurisdiction{AlBashirIndictment,
title = {Public Redacted Version of Prosecutor's Application for Warrant of Arrest under Art. 58},
shorttitle = {Al Bashir Application for Warrant of Arrest},
date = {2008-09-12},
number = {ICC-02/05-157},
court = {Pre Trial Chamber},
pagination = {paragraph},
tabulate= {ICC},
keywords={ICC}
}

@jurisdiction{Tadic,
title = {The Prosecutor v Dusko Tadi\'{c}, Appeals Judgment},
shorttitle = {Tadi\'{c} Appeals Judgment},
date = {1999-07-15},
number = {IT-94-1-A},
court = {Appeals Chamber},
pagination = {paragraph},
tabulate= {ICTY},
keywords={ICTY}
}

@jurisdiction{Vaillancourt,
title = {R. v Vaillancourt},
shorttitle = {Vaillancourt},
date = {1987},
court = {Supreme Court of Canada},
reporter = {S.C.R.},
volume = {2},
pages = {636},
pagination = {paragraph},
location = {Canada},
}
4

This is burried deeply in the manual of oscola, see p. 9:

\usepackage[backend=biber, style=oscola, indexing=cite,
 citereset=chapter]{biblatex}

Please note: "citereset=chapter".

Oh, and by the way, this code is not necessary:

\makeatletter   % the commands to ensure footnotes start new numbering at each chapter
\@addtoreset{footnote}{chapter}
\makeatother 

I suggest to add "english" to the global options and

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{babel}

to your preamble.

Please make sure your bib-file has UTF-8 encoding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.