I am having an error compiling the following code with xelatex and lualatex:

** WARNING ** "seac" character deprecated in Type 2 charstring. ** ERROR ** Type2 Charstring Parser: Parsing charstring failed: (status=-1, stack=5)

Output file removed.


\usepackage{xunicode} \usepackage{fontspec}

\setmainfont[Mapping=tex-text,Ligatures={Common}, Numbers={OldStyle}]{IM FELL English PRO} \begin{document}

Buongiorno a tutti. Trallallà.


The error disappears when I omit the accented à. It also doesn't happen when I use other fonts.

Could you suggest any workaround?

Thank you, A

  • 1
    Does the font have the à character in it?
    – Nigel
    Sep 17 '14 at 5:49
  • Yes, it does have it.
    – user56153
    Sep 17 '14 at 7:02
  • 1
    I guess it's the same problem as tex.stackexchange.com/questions/200402/…
    – egreg
    Sep 17 '14 at 9:07
  • 1
    Is XeTeX/LuaTeX a requirement or could you use pdfTeX if that was an option? I ask because I have an old package which provides support for the use of the IM Fell fonts with LaTeX. I cannot release that package due to licence restrictions on the versions of the fonts I used. However, I see that IM has evidently had a change of heart and is now using the SIL licence. Moreover, truetype versions are available under the new licence. If the truetype versions have not changed too much, it should be possible to generate a package to support the SIL-licensed truetypes...
    – cfr
    Sep 18 '14 at 1:43
  • 1
    However, that would involve some work and is not something I would do unless I thought there was some interest in having such a package. Given the popularity of Xe/LuaTeX, it isn't clear to me how much interest there is in such packages at this point. [Also, this is not something I could do instantly. So if time is a limiting factor, this definitely isn't a good option.] Perhaps it would be preferred to just find an alternative font family?
    – cfr
    Sep 18 '14 at 1:44

It seems to be a bug in «version 29» of the fonts: if you download them from the fontsquirrel site, they work as expected.

  • 1
    According to otfinfo and FontForge, the fonts at FontSquirrel and those at www.iginomarini.com are both version 3.00. But the latter, when opened in FontForge, produce many warnings about “SEAC-like endchar.” The only way I know how to get rid of those warnings is explained by @YangchenLin in his answer of 25 September. Perhaps the people at FontSquirrel did something like that?
    – Thérèse
    Jan 21 '15 at 1:00
  • @Thérèse I didn't check the FontForge data. I was only (mis)guided by the end numbers in the file names. However, the FontSquirrel versions were uploaded —according to the site— on 2008.
    – Ludenticus
    Jan 21 '15 at 1:08

Try opening the font in FontForge, re-exporting it without any edits, installing the re-exported font file in place of the original and running LaTeX again. On my system the accented letters display successfully after this procedure. I'm not sure why it works, unfortunately.

  • It works with accented characters, but still doesn't work for my entire file, probably many other glyphs are not compatible. Thanks for sharing anyway!
    – user56153
    Sep 26 '14 at 6:56
  • Like you, I have no idea why this works, but a big thank you! This trick fixed a commercial font I bought but could not use because it produced errors whenever the vowel i appeared.
    – Thérèse
    Sep 26 '14 at 21:45
  • You're very welcome. If multiple commercial and free fonts are having this issue, maybe it's an early sign of an impending 'digital dark age' when LaTeX can no longer read external fonts... Sep 27 '14 at 9:50
  • One thing I know about the IM Fell font is that it is 2048 UPM (most OpenType fonts are 1000 UPM). It seems unlikely but not impossible that this might break only some characters and that re-export would somehow fix it either partially or fully. Is your font 2048 UPM? Sep 27 '14 at 10:01
  • @YangchenLin No, it’s 1000 UPM. I have many fonts, and this was the only one that didn’t work, so I won’t worry about a dark age yet. Probably the software used to produce it did something odd. I always appreciated FontForge for the information it gave me about fonts; now I have another reason to love it.
    – Thérèse
    Sep 27 '14 at 13:59

A possible workaround is detailed here, where the problematic character is substituted with the same character from another font. For example:


\setmainfont{IM FELL English PRO}

%change this to your preferred alternative font




In the case of the Fell fonts, some version of Caslon could be used since those typefaces are very closely related. ITC Founder's Caslon (I don't have it to test) might work best since it has irregular characters like Fell, although it probably needs some FakeBold and scaling to match the weight and x-height of the Fell fonts. I concede it's not typographically ideal.

  • Interesting workaround. I hope sooner or later the support will improve.
    – user56153
    Sep 18 '14 at 11:26
  • 1
    This is a lot worse than not ideal. You will lose both kerning and hyphenation, I think. (Unless Xe/LuaTeX has very different magic. But certainly you'll lose kerning.)
    – cfr
    Jan 21 '15 at 2:52
  • The kerning looked fine when I tried it, and hyphenation won't cause too much trouble if it's just an occasional substitution. My biggest problem was with the inconsistency of character design. Jan 21 '15 at 7:40

I just came across this (xdvipdfmx:fatal: This font using the "seac" command for accented characters...) while testing some TT fonts including commercial fonts bought from Adobe and fonts from the old Bitstream and Fontsite "500-font" CD-ROMs, running XeLaTeX from TL2016 under Ubuntu 16.04.

By process of elimination I tracked it down to the NBSP (non-breaking space) character which was in the sample file immediately before each em rule (to prevent unwanted line-breaks). When I changed this character to TeX's version (tilde) the error went away and everything worked.

It only affected some fonts, for example Adobe Stone Serif Italic. Not sure why.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.