17

The scrbook class calculates margins automatically. For the title page of a book, I would like no margins at all, so that the text would be centered properly.

How can I disable all margins for the title page, and then reactivate them for the inside of the book?

  • Just FYI, the title page is inside the book, and should have normal margins. A book cover is not produced by the \maketitle macro – Koma script recommends (correctly) that a book cover resides in a separate document. – Konrad Rudolph Aug 12 '11 at 15:52
  • Thanks for your comment @Konrad. I was not mentioning the book cover, the title page. – ℝaphink Aug 12 '11 at 16:10
17

The geometry package offers you the \newgeometry and \restoregeometry commands to change page dimensions for some part of the document.

I would suggest, however, a different approach: design the title page as a different standalone document, with the desired page dimensions, and then use the pdfpages package to include this title page in your book.

10

For the record, the solution I chose uses pdfpages:

% No margins at all
\documentclass[paper=a5,pagesize=pdftex,DIV=100]{scrbook}

\begin{document}
\input{title}
\end{document}

I build this document with pdftex first, and I replaced:

\input{title.tex}

with

\includepdf{title_standalone.pdf}

in my main document.

  • You can change DIV inside a document using \KOMAoptions. So you do not need an external document. – Schweinebacke Mar 7 '17 at 12:49
10

You could use the new titlepage package of KOMA-Script and its environment fullsizetitle. This gives you a page without any margin.

Example:

\documentclass{scrbook}
\usepackage[english]{babel}
\usepackage{blindtext}
\usepackage{titlepage}
\begin{document}
\begin{fullsizetitle}
\blindtext[13]
\end{fullsizetitle}
\end{document}

title page without margins

  • Thanks, that's very useful. In the meanwhile, I redesigned my title page in Inskape because it was a bit too complex, so I'm sticking to PDF inclusion, but I'll keep that in mind :-) – ℝaphink Aug 14 '11 at 20:22
  • @Stefan Kottwitz : May I ask you what happened to the fullsizetitle-command? I fear it has not been implemented into KOMA, has it? – ClintEastwood Oct 5 '15 at 19:09
  • @ClintEastwood Did you use the titlepage package? – Stefan Kottwitz Oct 5 '15 at 21:30
  • @StefanKottwitz It cannot be found on my system (mactex). It seems that it is not part of the distribution. But why? – ClintEastwood Oct 6 '15 at 3:59
  • @StefanKottwitz : I mean the fullsizetitle-command (and maybe also the rest of titlepage) is so useful that it should be part of KOMA without having to install a new package. Or is it still in alpha/beta? – ClintEastwood Oct 7 '15 at 9:35
4

I had same same issue and discovered, that for more recent versions of KOMA-Script (from 3.12 on), there is the option titlepage=firstiscover present to achieve exactly, what you were looking for.

Just use it as option for your documentclass:

\documentclass[titlepage=firstiscover]{scrbook}

With

\renewcommand*{\coverpagetopmargin}{0mm}
\renewcommand*{\coverpageleftmargin}{0mm}
\renewcommand*{\coverpagerightmargin}{0mm}
\renewcommand*{\coverpagebottommargin}{0mm}

the margins can be removed or likewise set as intended.

  • I used that yesterday as well :-) Different margins in title and chapters – Johannes_B Jan 19 '15 at 17:12
  • 4
    Unfortunately, this only works for standard title pages automatically generated with the \maketitle command. Title pages defined in the titlepage environment are unaffected. – Stephen Bosch Jun 10 '15 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.