2

I'm trying to type some Hebrew in my document, which is mainly in English and German. The document compiles, but there are no Hebrew letters in the output. The log shows lots of messages like

Missing character: There is no ו in font frank!

Minimal example:

\documentclass{scrbook}
\usepackage[combine]{ucs}
\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\makeatletter\let\l@hebrew\l@nohyphenation\makeatother
\usepackage[hebrew,english,ngerman]{babel}
\usepackage{hebfont}
\usepackage{culmus}
\begin{document}
\R{וְאָהַבְתָּ לְרֵעֲךָ כָּמוֹךָ}
\end{document}
  • 2
    Welcome to TeX.SX! I'm not sure if utf8xresults better choice than utf8, in the other hand, maybe the set T1 of fontenc doesn't contains the Hebrew characters. Finally the error tells you that the font you're using hasn't the Hebrew character you need. – Aradnix Sep 19 '14 at 8:16
  • 1
    You probably need a \selectlanguage{hebrew} (I get a lot of errors with your example and I don't see where the font frank should come from so I have some doubts that your example is real). – Ulrike Fischer Sep 19 '14 at 8:32
  • If you are willing to use LuaLaTeX or XeLaTeX to compile, you can write in Hebrew very simply. If you use the libertine package for your font, you don't even need to select a Hebrew font or use any commands. You just type Hebrew unicode characters and it works out. – musarithmia Sep 19 '14 at 11:52
  • Thank you, libertine works perfectly! – Simon Plasger Sep 20 '14 at 14:00
  • 1
    @JúdaRonén See this excellent answer, which shows how to do right-to-left just using fontspec in LuaLaTeX without bidi: tex.stackexchange.com/questions/65141/… . I don't actually know Hebrew yet, so I can't answer your second question, sorry. – musarithmia Dec 9 '14 at 2:25
3

The problem is that the culmus-latex package does not support Nikud by default and doesn't seem to like the combine option to ucs. If you remove that option and the Nikud, you example compiles just fine.

\documentclass{scrbook}
\usepackage{ucs}
\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\makeatletter\let\l@hebrew\l@nohyphenation\makeatother
\usepackage[hebrew,english,ngerman]{babel}
\usepackage{hebfont}
\usepackage{culmus}
\begin{document}
\R{ואהבת לרעך כמוך}
\end{document}

If you need Nikud, have a look at the hiriq example from the culmus-latex source. It requires an additional file to map the Nikud symbols and using PostScript when generating output (you may later call ps2pdf to generate a pdf).

Disclosure: I maintain the culmus-latex package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.