5

I would like to have the title of references and index in small caps in the table of contents, but, as you can see in the following mwe, it's not the case. Is anyone there to help me ?

 % book example for classicthesis.sty
\documentclass[11pt,a4paper,footinclude=true,headinclude=true]{scrbook} % KOMA-Script book
\usepackage[T1]{fontenc}   
\usepackage[applemac]{inputenc}    
\usepackage[frenchb]{babel}
\usepackage{setspace} 
\usepackage{hyperref} 
\usepackage{epigraph} 
\usepackage{scrpage2}
\usepackage[tight,french]{minitoc}
\usepackage{apacite}
\usepackage{lipsum}
\usepackage[parts,pdfspacing,dottedtoc]{../classicthesis} % ,manychapters
%\usepackage[osf]{libertine}
\usepackage[left=4cm,right=4cm,top=3cm,bottom=3cm]{geometry}
\newcounter{qcounter}
\usepackage{makeidx} 
\makeindex
\renewcommand\textflush{flushright}

\usepackage{etoolbox}
\makeatletter
\newlength\epitextskip
\pretocmd{\@epitext}{\em}{}{}
\apptocmd{\@epitext}{\em}{}{}
\patchcmd{\epigraph}{\@epitext{#1}\\}{\@epitext{#1}\\[\epitextskip]}{}{}
\makeatother

\setlength\epigraphrule{0pt}
\setlength\epitextskip{2ex}
\setlength\epigraphwidth{.8\textwidth}

 \FrenchFootnotes
 \usepackage{amsthm}
 \usepackage{lineno}
 \setcounter{tocdepth}{3}
 \setcounter{secnumdepth}{3}
 \AtBeginDocument{\renewcommand{\thepart}{\Roman{part}}}

 \frontmatter
 \begin{document}

 %  \pagestyle{scrheadings}
 %  \manualmark
 %  \markboth{\spacedlowsmallcaps{\contentsname}}{\spacedlowsmallcaps{\contentsname}}

 \pagestyle{scrheadings}

 \tableofcontents

  \clearpage
  ...
  \backmatter
  \bibnewpage 
  { \raggedright 
  \bibliographystyle{apacite} 
  \bibliography{mabiblio}}
  ...
  \end{document}
  • Please make your code compilable so that people can reproduce what you are seeing. If you are using a modified version of classicthesis as your code suggests, please tell us about any relevant changes. – cfr Sep 20 '14 at 16:30
  • 1
    OK. I've just modified my mwe. – domi Sep 20 '14 at 19:08
5

You could add the instructions

\usepackage[titles]{tocloft}
\renewcommand\cftchapfont{\scshape}

to the preamble, after loading the classicthesis package. With this addition in place, the table-of-contents page looks like this (note that there's no entry for the Index since the MWE didn't contain any indexing commands):

enter image description here

\documentclass[11pt,a4paper,footinclude=true,headinclude=true]{scrbook} % KOMA-Script book
\usepackage[T1]{fontenc}   
\usepackage[applemac]{inputenc}    
\usepackage[frenchb]{babel}
\usepackage{setspace} 
\usepackage{hyperref} 
\usepackage{epigraph} 
\usepackage{scrpage2}
\usepackage[tight,french]{minitoc}
\usepackage{apacite}
\usepackage{lipsum}
\usepackage[parts,pdfspacing,dottedtoc]{classicthesis} % ,manychapters
%\usepackage[osf]{libertine}
\usepackage[left=4cm,right=4cm,top=3cm,bottom=3cm]{geometry}
\newcounter{qcounter}
\usepackage{makeidx} 
\makeindex
\renewcommand\textflush{flushright}

\usepackage{etoolbox}
\makeatletter
\newlength\epitextskip
\pretocmd{\@epitext}{\em}{}{}
\apptocmd{\@epitext}{\em}{}{}
\patchcmd{\epigraph}{\@epitext{#1}\\}{\@epitext{#1}\\[\epitextskip]}{}{}
\makeatother

\setlength\epigraphrule{0pt}
\setlength\epitextskip{2ex}
\setlength\epigraphwidth{.8\textwidth}

 \FrenchFootnotes
 \usepackage{amsthm}
 \usepackage{lineno}
 \setcounter{tocdepth}{3}
 \setcounter{secnumdepth}{3}
 \AtBeginDocument{\renewcommand{\thepart}{\Roman{part}}}
\usepackage[titles]{tocloft}
\renewcommand\cftchapfont{\scshape}

 \begin{document}
 \frontmatter

 %  \pagestyle{scrheadings}
 %  \manualmark
 %  \markboth{\spacedlowsmallcaps{\contentsname}}{\spacedlowsmallcaps{\contentsname}}

  \pagestyle{scrheadings}

  \tableofcontents

  \clearpage
  ...
  \mainmatter
  ...
  \clearpage
  \backmatter

  \bibnewpage 
  { \raggedright 
  \bibliographystyle{apacite} 
  \bibliography{mabiblio}}
  ...
  \end{document}
  • It works ! Thanks. It works also for my index that I didn't mention in the MWE. But do you know why the table of contents indicates a wrong page number ? When I click on the index page number (235), the page number 237 appears. – domi Sep 20 '14 at 19:35
  • @domi - Not having access to your full file, I'm afraid I can't offer a solid diagnosis. Have you tried recompiling two times more, to fully propagate all changes? Does the page numbering issue go away if you uncomment (or remove) the tocloft-related instructions? – Mico Sep 20 '14 at 19:39
  • 1
    @domi - Try inserting the instruction \clearpage before \addcontentsline{toc}{chapter}{\indexname}. – Mico Sep 20 '14 at 19:46
  • 1
    @domi - I'm afraid that "it doesn't work" is rather uninformative. Please be more specific. In particular, please indicate if you ran LaTeX twice after inserting the additional \clearpage instruction. – Mico Sep 20 '14 at 20:22
  • 1
    Using \addcontentsline with a KOMA class is an indicator for not using the documented and well designed macros. How to use unnumbered chapters with KOMA-script? along with options like bibliography=totoc or KOMA book: correct hyperlink to the index? – Johannes_B Nov 4 '14 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.