3

I have texpad installed on my Mac, and would like to install a custom beamer style - Frederiksberg (can be found here: http://www.matdat.life.ku.dk/LaTeX/Frederiksberg/ )

The manual is not entirely exact on where to place the styles, as it was developed on linux. it mentioned a directory called /usr/local/gwTeX which i do not seem to have.

i have instead search quite a bit for a solutions, and it seems that the most common way to install custom styles is to make a couple of directories in ~/Libraries so that the styles are located in /Library/texmf/tex/latex/beamer/. as it is in my "personal tree" it should be enough to simple leave the styles there as the directories are searched automatically

it does, however, not work. texpad gives me the error:

! LaTeX Error: File `beamerthemeFrederiksberg.sty' not found.

texpad looked in the directory /usr/local/texlive/2013/texmf-dist/tex/latex/beamer/...

which of course prompted me try and put the the file in that directory - more specifically in /usr/local/texlive/2013/texmf-dist/tex/latex/beamer/themes/theme where there are already a bunch of beamer themes, such as "beamerthemeGoettingen.sty" and "beamerthemeWarsaw.sty". Goettingen and Warsaw worked, but Frederiksberg did not - i have double checked for spelling mistakes :/

does anyone know what the problems is? the "texmf/tex/latex/" solution does not appear to work with texpad on my computer, and neither does placing it with the other styles.

EDIT: thought i might share the code also

\documentclass[12pt,t]{beamer}

\usetheme{Frederiksberg}

\title{My Nice Presentation}
\subtitle{Test}
\author{Productive Scholar}
\date{\today}
\institute[2014]{KU-SUND}

\begin{document}
\frame[plain]{\titlepage}

\end{document}
  • 2
    You should NOT put it under /usr/local/texlive/2013/ as that should be reserved for the TeX distribution. (The reason it doesn't work is because TeX relies on a database of hashed names to find things in that directory.) You have two options. One is your personal texmf tree. The other is /usr/local/texlive/texmf-local/ [note that this is NOT under a directory named for a year]. The first is easier. Try <your home directory>/Library/texmf/tex/latex/beamer/themes/. Note that you should NOT use /Library. You want to use <your home>/Library/. – cfr Sep 20 '14 at 22:55
  • 1
    I think that the correct place to put this is in /usr/local/texlive/texmf-local/tex/latex/local/, for a system-wife installation, and otherwise somewhere in your home directory (such as ~/Library/texlive/... as suggested already). – Andrew Sep 21 '14 at 6:21
  • @Andrew: A system-wife installation? ;-) O-o-o-o ;-) Off-topic comment, I know ;-) – user31729 Sep 21 '14 at 7:44
  • Cheers cfr! Now it works - how do i mark your reply as the solution/asnwer ? – DonMP Sep 21 '14 at 8:12
  • 1
    @ChristianHupfer Yeah, well, I'm IT-support at home (and can't type:) – Andrew Sep 21 '14 at 9:29
5

You should NOT put custom or personal additions under /usr/local/texlive/2013/ as that directory should be reserved for the TeX distribution. Changes you make there can easily be overwritten when you update the installation and will certainly be lost if you switch to, say, TeX Live 2014.

The reason it doesn't work when you add the theme there is because TeX relies on a database of hashed names to find things in that directory. You would have to also update that database in order for the theme to be found.

You have two options.

  1. Your personal texmf tree. TeX does not use a hashed database to search this directory - it just looks at what is there at the time of compilation.
  2. /usr/local/texlive/texmf-local/ [note that this is NOT under a directory named for a year]. TeX does use a hashed database for this directory. So if you use this one, you need to update that database in order for the theme to be found.

The first option is easier since all you need do is put the file in the correct place - no need to worry about updating any database.

Try placing the theme in <your home directory>/Library/texmf/tex/latex/beamer/themes/ to mirror the directory structure you found in your main texmf tree. Note that you should NOT use /Library. You want to use <your home>/Library/.

If you did want to use the local texmf tree rather than your personal one - perhaps because other users of the machine should have access to the same theme - you could use /usr/local/texlive/texmf-local/tex/latex/beamer/themes/. To update the database of names, you would then need to run mktexlsr /usr/local/texlive/texmf-local. (You could just run mktexlsr but it is a little quicker to specify the appropriate texmf tree.)

  • 1
    Only 12 rep left to be a trusted user ;-) – user31729 Sep 21 '14 at 12:08
  • @ChristianHupfer I guess so but trusted by whom?! – cfr Sep 21 '14 at 12:11
  • By every other trusted user ;-) And of course by me ;-) – user31729 Sep 21 '14 at 12:13
  • @ChristianHupfer I can't up-vote that comment because I've run out of votes. (Have they changed the number of votes you can use? Until yesterday, I don't think I ever ran out of votes for comments. Now I've done it again.) – cfr Sep 21 '14 at 12:17
  • I don't now -- I never ran out of comment votes so far. If you still feel driven to upvote that comment, you can do it later on ;-) – user31729 Sep 21 '14 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.