1

I am creating a document in greek, using babel and utf8 encoding. I am using MiKTeX 2.9 and TeXMakeR. When trying to produce a document I get the error

Package inputenc Error: Unicode char \u8:Γ not set up for use with LaTeX

My code is

\documentclass[11pt]{book}

\usepackage[english,greek]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1,LGR]{fontenc}

\begin{document}
Γεια σου κόσμε!
\end{document}

Note that I have changed my editor's encoding in utf8. Any idea how to fix it?

closed as unclear what you're asking by egreg, Paul Gessler, Joseph Wright Apr 11 '15 at 21:16

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    inputenc option utf8 definitely doesn't work for greek; iirc, utf8x does cope with greek; however, if at all possible, you're better off using xelatex, which doesn't need any dances to make utf-8 work – wasteofspace Sep 23 '14 at 15:52
  • Please, try updating all MiKTeX packages and try again removing the LGR option. Can you add \listfiles to your example, compile and add to your question what you'll find in the log file after * File List *? – egreg Sep 23 '14 at 15:53
  • 1
    @wasteofspace utf8 does work for Greek, provided the TeX distribution is up-to-date. Here's the picture of the output I get from Qubit's code. – egreg Sep 23 '14 at 16:01
  • 1
    I have no problem compiling this. Perhaps the file was first not utf8 encoded? Then asking for utf8 encoding set up a mess. Try retyping in a new file. – Bernard Sep 23 '14 at 16:01
  • 1
    @Bernard The error message shows a Gamma, so that's not the problem. – egreg Sep 23 '14 at 16:02