1

For my thesis I am using the scrreprt document class for my document. The problem is that using this document class, you are forced to use chapters for each separate appendix (so appendix A, B et cetera). As my chapter headings take up much space (I like the twoline headings KOMA-Script offers, in which the first line is "Chapter 1." and the second is the title), I get lengthy appendices with relatively small type areas due to the large headings.

What I would like is to create smaller headings for my appendices whilst still maintaining the A, B, C et cetera numbering. One of two approaches would be nice:

  1. Use \section in stead of \chapter for appendices. Thus using the smaller typeset section headings within my appendices. Currently I can't get this right, when I use sections my numbering switches from A, B, C etc to .1, .2, .3 which, clearly, is not what I want.
  2. Manually adjusting the chapter heading for my appendices. KOMA-Script seems to have options for this (particularly headings=onelineappendix), but it set the headings for the entire document. I.e. changing this option means oneline headings for body chapter headings and appendices (which clearly is not what I want).

I hope anybody can help me achieve one of the two approaches.

  • \clearpage\KOMAoption{headings}{small}\appendix might just be enough. – Johannes_B Sep 23 '14 at 18:14
5

You can combine headings=twolinechapter with headings=onelineappendix

\documentclass[
    headings=twolinechapter, % or chapterprefix=true
    headings=onelineappendix % or appendixprefix=true
  ]{scrreprt}
\usepackage{blindtext}
\begin{document}
\tableofcontents
\blinddocument
\blinddocument
\appendix
\blinddocument
\blinddocument
\end{document}

If the chapter headings in the appendix should have the same size as section headings you can use

\documentclass[
  headings=twolinechapter% or chapterprefix=true
]{scrreprt}
\usepackage{blindtext}
\begin{document}
\tableofcontents
\blinddocument
\blinddocument
\appendix
\setkomafont{chapter}{\usekomafont{section}}
\blinddocument
\blinddocument
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.