1

I just installed Ubuntu 14.04 and it comes with a basic TeX installation. I use LaTeX a lot and many of my packages don't come with ubuntu TeX installation. It's difficult and time consuming to download missing packages, go through all their files, read instructions, and put each file in the right directory. So I just installed texlive-full.

Although all packages are now installed (/usr/share/...), pdflatex (on terminal) does not find them. How can I find and set the right TexLive path for pdflatex?

I did run texhash.

In TUG, it says add this to your .bashrc:

   PATH=/usr/local/texlive/2014/bin/i386-linux:$PATH 

But I don't have that path on my system. Where is the path to texlive binaries and how to export it? I don't even have "x86_64-linux" under any /texlive/ directory.

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Symbol 1 Sep 23 '14 at 17:31
  • I think Ubuntu does some strange stuff with config files, anyway, take a look at this answer: tex.stackexchange.com/a/95373/24483 and see if it helps you. – Nico Boni Sep 23 '14 at 17:35
  • It assumes that you know the path to texlive binaries. I do not have his path, instead, I have "usr/share/texlive/texmf-dist/source/latex/koma-script/doc/bin", which just contains two .pl files. Doesn't seem to be the right path. – eli Sep 23 '14 at 17:54
  • 1
    Did you intall through Apt? If so, you should not be adding any PATH information. If you added that line to your .bashrc, delete it and do source .bashrc (or restart computer) before trying to do any other 'fixes'. – jon Sep 23 '14 at 18:30
  • I installed from command line: sudo apt-get install texlive-full – eli Sep 23 '14 at 22:16
2

If you install the Debian package texlive through the package manager (apt, aptitude), then you should not set the path.

If you install separately by downloading tlmgr from the TeXLive website, then you do need to set the path (preferably in ~/.profile, not ~/.bashrc, but opinions differ).

  • That is correct. – eli Sep 23 '14 at 22:23
  • You should point out that ~/.bashrc is shell-dependent. It will do you no good if you are using zsh, say. Also, if you install system-wide /etc/profile.d/local_texlive.sh and /etc/profile.d/local_texlive.csh or whatever are not bad choices. – cfr Sep 24 '14 at 0:18
0

my guess is that you have the texlive package installed, but not texlive-full. If this is true, there are two options:

  • install texlive-full with apt-get or your favorite package managers. It will bring you most packages there are, but a few released only recently.

  • if you go for the installation of TeX Live from TUG, install to the default, and then adapt your .bashrc to add the parh.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.