I had hoped to use the Minion and Myriad fonts from my new copy of Adobe CS 5 in XeLaTeX; but \setmainfont{Minion Pro} produces the following error: (output of xdvipdfmx -vvv shown)

DVI File Info
Unit: 25400000 / 473628672
Magnification: 1000
Media Height: 41484288
Media Width: 26673152
Stack Depth: 3
Page count: 1
DVI Comment: XeTeX output 2010.08.20:1057
DVI file font info
TeX Font: MinionPro-Regular loaded at ID= 16, size= 9.96pt (scaled 100.0%)
tufte.xdv -> tufte.pdf
D:/TEMP/dvipdfmx.a0056400001 [1 ** ERROR ** Cannot proceed without the "native" font: MinionPro-Regular (Minion Pro Regular)...
Output file removed.

Variations of the argument, such as MinionPro, MinionPro-Regular, Minion Pro Regular, etc., also produce the error. Refreshing the font cache, with fc-cache -fv, doesn't change anything either.

I have determined that it is the output driver, xdvipdfmx, that is causing this error, since invoking xelatex with --no-pdf works without any problems. Apparently XeLaTeX can find the font, but the output driver can't.

To make things even more bizarre, if I select the font like this:


everything works as expected. Can somebody advise me as to what is going on here?

UPDATE: I changed above to show the output of xdvipdfmx -vvv.

  • I’ve got the same problem with TeX Gyre Pagella. A bit of googling reveals that quite a few people seem to be having this problem. Incidentally, using the (deprecated, I understand?) xdv2pdf instead of xdvipdfmx works so this is may point to a bug in the latter driver. Sep 12, 2010 at 13:38
  • FWIW: I had the same problem on Mac OS X, and the fix was to move the fonts from my local directory (~/Library/Fonts) to the system directory (/Library/Fonts). Thanks to Khaled's comment on his answer. Sep 25, 2011 at 11:54

2 Answers 2


An update to TeX Live 2010 solved the problem for me. Apparently, this is a problem specific to XeTeX 0.9996.

  • I ran into this issue yesterday with one of my fonts, today I can't reproduce it. I'm not sure what solved it, but cleared my fontconfig cache several times in between (I'm on Linux), also the font itself were slightly changed. So, I'd first try to clear system font cache and see. Sep 12, 2010 at 15:46
  • I can confirm that upgrading to 2010 solved my problem too.
    – ptomato
    Oct 8, 2010 at 14:01

You can try running xdvipdfmx on the XDV file with ascending verbosity levels, -v, -vv, -vvv etc. probably you will be able identify some possible cause.

  • See update to question - still stumped, unfortunately.
    – ptomato
    Aug 20, 2010 at 9:05
  • 2
    Do you have the font installed on the system i.e. you can access it with system applications? The fact that the font can be loaded by file name and not by font name is likely to mean that you have installed the font in your TEXMF tree. Unfortunately, XeTeX can't find fonts in the TEXMF tree by font name, you have to install the fonts system wide for this to work (and when doing so, don't forget to delete the TEXMF copy as its co-existence can cause other problems). As a side note (a bit of advocating one's own work), LuaLaTeX in texlive2010 can load fonts by font name either way. Aug 20, 2010 at 13:29
  • Yes, it's installed on the system, and not in the TEXMF tree. It seems that XeTeX can find the font just fine (since it complains when I replace Minion Pro with a nonsense font name), it's xdvipdfmx that can't find it.
    – ptomato
    Aug 23, 2010 at 9:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .