4

I'm trying to install TeX Live in my home directory in Ubuntu 12.04, where I don't have sudo rights. I'm installing from the Live CD.

But install-tl always wants to install in /usr/local/bin and stops because I don't have the access rights.

In the texlive install documentation, the sentence:

"install-tl --profile=profile does a batch (unattended) installation. To create such a profile file, it's easiest to start with the tlpkg/texlive.profile file which the installer writes at the end of any successful installation."

Sounds to me as if I could only install-tl using a custom profile after a successful installation, so that for the start I don't see a profile I could overwrite. Using the Unix find function I couldn't find anything called *.profile in the CD.

How can I call install-tl so that everything gets installed in a very usual configuration similar to the sudo installation, except that instead of using /usr/local or any root-owned directory, everything goes to my ~/.local,~/.local/bin, ~/.local/doc, ~/.local/etc, ~/.local/share, ~/.local/include, ~/.local/lib, and ~/.texlive2014?

Edit: @dartbirth and @Andrew Cashner, thanks a lot. It's true that I hadn't read the install-tl ui carefully enough. My console is too narrow and just showed the last lines of the install-tl ui text, hiding the directory configuration part. It's as silly as that. Now the internet installer is running and I hope to be asking for closing this issue very soon. Thanks again.

  • Welcome to TeX.SX! – mvkorpel Sep 26 '14 at 10:05
  • Related (but not duplicate I don't think, since most answers there require root access): tex.stackexchange.com/questions/1092/… – darthbith Sep 26 '14 at 12:37
  • 1
    No time for a full answer, but running install-tl -gui=text (or the wizard, I suppose) gives you the option to change the installation directories... did you try that? – darthbith Sep 26 '14 at 12:40
  • Why are you using a profile in the first place? I do think one can specify the installation dir in a profile but I do not know how as I never use them. Since you do not have sudo access, why don;t you ask your system admin to install a better LaTeX installation. Seems to benefit more than one user. – daleif Sep 26 '14 at 12:51
  • Just look through the installer options carefully and you'll see an option to change the install directory. – musarithmia Sep 26 '14 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.