1

I am using the report class and want to eliminate the Appendices page without eliminating the actual individual appendices. I have the capitalization of the appendices as I want (all caps). I am trying to:

  1. Remove the Appendices page (page 5)
  2. Remove Appendices page from the Bookmarks and un-nest the individual Appendices from the previous part
  3. Remove Appendices page from TOC

So currently the setup at the bottom looks like this:

Bookmarks
enter image description here

TOC
enter image description here

Pages
enter image description here

I'd like it to look like (I cut and pasted the images to make them look this way; i.e., I don't have code that made the desired output pics)...

Bookmarks
enter image description here

TOC
enter image description here

\documentclass[12pt]{report}
\usepackage[T1]{fontenc}
\usepackage{filecontents}
\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=apa, backend=biber]{biblatex}
\addbibresource{biblatex-examples.bib}
\DeclareLanguageMapping{american}{american-apa}
\usepackage{setspace}
\usepackage{bookmark}
\usepackage[title,titletoc,toc,page]{appendix}
\usepackage{hyperref}
\hypersetup{
    colorlinks=true,
    linkcolor=blue,
    filecolor=magenta,
    urlcolor=blue,
    citecolor=blue,
}
\setcounter{secnumdepth}{0}
\usepackage{tocloft}
\renewcommand{\cftchapleader}{\cftdotfill{\cftdotsep}} 

\begin{document}
\nocite{*}

\newpage
\pdfbookmark[section]{\contentsname}{toc}
\tableofcontents 

\part{Top Level}
\chapter{First Chapter}
Foo
\chapter{Last Chapter}
Bar

%% Appendices
\begin{appendices}
\renewcommand{\appendixname}{APPENDIX}

\chapter{Foo}
some text

\chapter{Bar}
some more text
\end{appendices}

%% References
\newpage
\singlespacing
\bookmarksetup{startatroot}
\addcontentsline{toc}{chapter}{REFERENCES}
\renewcommand{\bibname}{REFERENCES}
\printbibliography

\end{document}

EDIT

Using @barbara beeton's suggestion (and dumping the appendix package):

\appendix
\renewcommand{\appendixname}{APPENDIX}

\chapter{Foo}
some text

\chapter{Bar}
some more text

But this Removes the APPENDIX prefix and does not un-nest the individual appendices bookmarks from the last part bookmark (They're under Top Level) so they look more like REFERENCES

enter image description here

  • the report class has a command \appendix which merely changes the numbering system for \chapter to use letters, and changes "Chapter" to "Appendix". i don't know the appendix package, but am pretty sure that it's the appendix environment from that package that is adding the extra page. try omitting that and just using the simple \appendix. enclose it in a group if the running heads in the bibliography are affected adversely. – barbara beeton Sep 26 '14 at 14:45
  • @barbarabeeton Thank you for your suggestion. That's where I started from but there were no APPENDIX prefix and the appendices bookmarks were still nested under the last part. I show this in the edit above. – Tyler Rinker Sep 26 '14 at 15:01
  • i think i've found an easy fix; i can't promise it doesn't have other side effects, but it looks reasonable. restore the appendix package, and in your preamble, add the line \renewcommand{\addappheadtotoc}{}. – barbara beeton Sep 26 '14 at 15:30
  • Via section 2 of the appendix documentation, it appears that the page option in your \usepackage line is what causes the extra separator page. You may only want to use the title and titletoc options instead. – Mike Renfro Sep 26 '14 at 15:32
  • @MikeRenfro this is the best option I think to get rid of the Appendices page. Thank you. Any thought on how to un-nest the Appendix A and Appendix B from under Part 1? – Tyler Rinker Sep 26 '14 at 22:08
1

Based on @MikeRenfro's comment:

Via section 2 of the appendix documentation, it appears that the page option in your \usepackage line is what causes the extra separator page. You may only want to use the title and titletoc options instead.

I also added \bookmarksetup{startatroot} for each of the appendices to un-nest them from part 1:

\documentclass[12pt]{report}
\usepackage[T1]{fontenc}
\usepackage{filecontents}
\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=apa, backend=biber]{biblatex}
\addbibresource{biblatex-examples.bib}
\DeclareLanguageMapping{american}{american-apa}
\usepackage{setspace}
\usepackage{bookmark}
\usepackage[title,titletoc]{appendix}
\renewcommand{\addappheadtotoc}{}
\usepackage{hyperref}
\hypersetup{
    colorlinks=true,
    linkcolor=blue,
    filecolor=magenta,
    urlcolor=blue,
    citecolor=blue,
}
\setcounter{secnumdepth}{0}
\usepackage{tocloft}
%\renewcommand{\cftpartleader}{\cftdotfill{\cftdotsep}} 
\renewcommand{\cftchapleader}{\cftdotfill{\cftdotsep}} 

\begin{document}
\nocite{*}

\newpage
\pdfbookmark[section]{\contentsname}{toc}
\tableofcontents 

\part{Top Level}
\chapter{First Chapter}
Foo
\chapter{Last Chapter}
Bar

%% Appendices
\begin{appendices}
\renewcommand{\appendixname}{APPENDIX}
\bookmarksetup{startatroot}
\chapter{Foo}
some text

\bookmarksetup{startatroot}
\chapter{Bar}
some more text
\end{appendices}

%% References
\newpage
\singlespacing
\bookmarksetup{startatroot}
\addcontentsline{toc}{chapter}{REFERENCES}
\renewcommand{\bibname}{REFERENCES}
\printbibliography

\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.