8

How can we trace back to the actual bib file the (most likely formatting) error that makes biber die?

The error I get from the biber run is:

[1447] Utils.pm:160> ERROR - BibTeX subsystem: /tmp/wLejLsez1J/Passivity.bib_28895.utf8, line 8851, syntax error: found ",", expected one of: number, name (entry type, key, field, or macro name), end of entry ("}" or ")") or quoted string ({...} or "...")

All this tells me is that there is an error in the file Passivity.bib. That file has several hundred refs, however. How can I get to the problematic one?

The file in /tmp that biber refers to does not exist any longer at the end of biber's run.

I tried checking the .blg file produced by biber, but it contains exactly the same information as the line above.

6
  • 6
    By going to the line mentioned in the error message: line 8851. Probably there is a second comma. – Ulrike Fischer Sep 26 '14 at 16:10
  • 2
    Thanks Ulrike! I didn't know that the line number in the error message actually referred back to the original bib file. I took it as a reference to the disappeared tmp file. Problem solved! (it was indeed a trivial syntax error, as you guessed) – stefano Sep 26 '14 at 16:23
  • 4
    This question appears to be off-topic because it is about a trivial syntax error. – Sean Allred Sep 26 '14 at 16:27
  • 4
    @SeanAllred: The error was trivial---where to find it in the bib file was not. In fact I would dare say it is a bug in biber---the error message should make clear that /tmp/wLejLsez1J/Passivity.bib_28895.utf8, line 8851 actually means line 8851 of Passivity.bib. – stefano Sep 26 '14 at 18:50
  • @stefano: where did you find that error message with the line number in it? I had a similar problem (tex.stackexchange.com/q/229866/4009), but the .blg file did not give any line number where the error occured. – MostlyHarmless Feb 25 '15 at 5:12

Browse other questions tagged or ask your own question.