I'm running the latest Mac OS X 10.10 Yosemite beta, and I ran into a problem installing MacTeX (2014) and LyX (2.1.2). Upon successful installation of both, LyX would launch with an error: "Document Class Not Available", and only the LyX document classes would show up under Document > Settings > Document Class.

I'm sure others will be running into this problem soon, so what steps do I need to take to solve this problem?

  • 1
    We'd like to keep answers separate from questions, so you should write a separate answer instead of editing your answer into the question. Self-answers are perfectly admissible, and a well-written answer may earn you additional reputation.
    – Werner
    Sep 30, 2014 at 1:08

1 Answer 1


Well, I managed to figure it out myself, but I want the procedure to be available to anyone. The error seems to be a result of LyX looking for the wrong installation of Python. In OS X 10.10, the Python version is 2.7.6, causing a problem according to this page.

The steps I took to fix the problem are:

  1. Run LyX from Terminal.app by typing the following then pressing enter:


  2. Once LyX is running from the terminal, select the menu option Tools > Reconfigure. You should see LyX running through a checklist in the Terminal. Let it finish. Once this procedure complete, quit LyX and Terminal, and try restarting LyX.

It took me two tries, but LyX is back up and running for me.

  • Thank you very much for helping me to get rid of those annoying document class not available messages caused by Yosemite!
    – Joel Purra
    Oct 23, 2014 at 16:00
  • Tried this, didn't work for me.
    – Veridian
    Apr 27, 2015 at 1:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .