9

I am working on a critical edition of ancient Greek poems and I am using the verse environment of LaTeX. I need two basic footnotes and I am currently using manyfoot. I have defined another line spacing for the footnotes, which seems to work fine, at least for the small value that I need (code + first image).

\documentclass[12pt]{book}

\usepackage{polyglossia}
\usepackage{verse}
\usepackage[para]{manyfoot}

\setdefaultlanguage{greek}
\setotherlanguage{english}
\newfontfamily\greekfont[Script=Greek,Ligatures=TeX]{Times New Roman}

\def\extrafootnoterule{\defaultfootnoterule}
\newfootnote[para]{A}
\newfootnote[para]{B}
\interfootnotelinepenalty=10000
\def\mylinespacing{1.05}
\newcommand{\foota}[1]{
  \begingroup
  \linespread{\mylinespacing}
  \FootnotetextA{}{\textbf{\arabic{poemline}} #1}
  \endgroup%
}
\newcommand{\footb}[1]{
  \begingroup
  \linespread{\mylinespacing}
  \FootnotetextB{}{\textbf{\arabic{poemline}} #1}
  \endgroup
}

\usepackage{showframe}

\begin{document}

\verselinenumbersleft
\settowidth{\versewidth}{ααααααααααααααααααααααααααααααααααααααααα}

\chapter*{CANON I}
\poemlines{5}

\begin{verse}[\versewidth]

\vin ᾠδὴ . \textit{Θαυμαστὸς ἐνδόξως ποιῶν τέρατα}\foota{heirm. α΄ EE 76, n. 108, Andreae}

\vin Τὴν πύρινην γλῶτταν,\foota{Τὴν πύρινην γλῶτταν}\\*
τὸν νοῦν τὸν ἄϋλον,\foota{Τὴν πύρινην γλῶτταν}\\
τῶν θεωριῶν\foota{Τὴν πύρινην γλῶτταν}\\
τὴν σάλπιγγα τὴν θείαν,\footb{Τὴν πύρινην γλῶτταν}\footb{Τὴν πύρινην γλῶτταν}\\
τὸ στόμα τῆς σοφίας,\foota{Τὴν πύρινην γλῶτταν}\\
τὸν μέγαν θεολόγον\\*
θείοις ὕμνοις ἀνευφημήσωμεν.\foota{Τὴν πύρινην γλῶτταν}\\!

\vin Τὴν πύρινην γλῶτταν,\foota{Τὴν πύρινην γλῶτταν}\\*
τὸν νοῦν τὸν ἄϋλον,\footb{Τὴν πύρινην γλῶτταν}\\
τῶν \footb{Τὴν πύρινην γλῶτταν}θεωριῶν\footb{Τὴν πύρινην γλῶτταν}\\
τὴν σάλπιγγα τὴν θείαν,\\
τὸ στόμα τῆς σοφίας,\footb{Τὴν πύρινην γλῶτταν}\\
τὸν μέγαν θεολόγον\footb{Τὴν πύρινην γλῶτταν}\\*
θείοις ὕμνοις ἀνευφημήσωμεν.\\!

\vin Τὴν πύρινην γλῶτταν,\\*
τὸν νοῦν τὸν ἄϋλον,\\
τῶν θεωριῶν \footb{Τὴν πύρινην γλῶτταν}\\
τὴν σάλπιγγα τὴν θείαν,\footb{Τὴν πύρινην γλῶτταν}\\
τὸ στόμα τῆς σοφίας,\\
τὸν μέγαν θεολόγον\footb{Τὴν πύρινην γλῶτταν}\\*
θείοις ὕμνοις ἀνευφημήσωμεν.\foota{Τὴν πύρινην γλῶτταν}\\!

\end{verse}

\end{document}

1st image

The issue comes up because of the special layout I need for these footnotes. For example, some specific footnotes need to occupy a single line. Until now I used the command \newline at the end of the "lonely" footnote (and at the end of the previous footnote). Unfortunately, this seems to cause a problem, as the footnotes may overlap with the page numbers. As shown in the second image, the footnote is also escaping from the text box. The example may seem exaggerating, but the phenomenon does occur in almost 10% of my pages (which translates to more than 30 pages).

In addition, I need to modify the footnote ruler and increase its separation from the text above and below. Currently I am using the following code:

\renewcommand{\footnoterule}{
\kern 5.52pt
\hrule width 3cm
\kern 10.52pt}

As expected, this further deteriorates the problem:

2nd image

I would appreciate any help concerning this issue. I use the manyfoot package more out of a coincidence, as it seemed more flexible for the definition of many different types of footnotes (some printing the verse number, some without etc.). I also considered bigfoot and footmisc. I would prefer to stick to manyfoot, but I could try to transfer everything to another package which could indeed face the mentioned problem of the footnote layout.

  • Welcome to TeX.SX! – user31729 Sep 30 '14 at 17:08
  • 2
    for critical edition, you should look at eledmac. – Maïeul Sep 30 '14 at 21:51
  • @Christian, thank you for the welcome! @Maïeul, the use of eledmac would require a complete restructure of my code. However, I spent some time reading the package details more carefully. Unfortunately, it seems that this issue is neither faced by eledmac. The following image comes from an example of the package, entitled "Setting spaces around footnote rules": i.imgur.com/JkMgUWe.png. Furthermore, in the display options of the package details it states notes can be placed by the page number, at the bottom of the page, without offering a functional solution. – orestis21 Oct 1 '14 at 15:14
  • indeed you are right (for both problem). Thanks, you have send me a bug which I didn't sse (but not for you think). For your problem, I will say you an answer. – Maïeul Oct 1 '14 at 21:38
2

Your problem is quite complex to solve. I have found a way for eledmac (thank!) and for your specific problem with your MWE.

The problem is that adding space after the rule is problematic, because TeX doen't count this space as a space for notes. That's why it can override the line number.

The solution is quite complex, and need TeX knowledge.

A footnote is a TeX insert. For each TeX type of insert, there are three parameters :

  • a) length which is kept in the page only if a insertion is made. In your case, only if at least one \footnote is called.
  • b) length which say the maximum height all inserts can have in the same page.
  • c) factor which is used when a insertion is added, (ie a footnote in your case) which determines the height of the insertion. When the total of insertion*factor > b, the insert is full, and tex output it (to summarize).

If you change the a) length to add your kern after rule, it will solve the problem, because the space will be "reserved" by TeX in the total height of the notes. This a length is, with your package, equal to \footdimen.

So, if you change \footin, you will say to TeX to kept this space before printing insertion.

But, the problem is that \MFL@joinrule, the command called by manyfoot when printing extra footnotes rule use \footin to add space before the rule. So the space you want after the rule will be also add before the rule! The same is also true for \make@cols which is called by LaTeX and print the first rule in the series.

The solution is to patch \MFL@joinrule and \make@cols to delete this space before the rule, because it is the space after the rule.

We can do it with etoolbox (which is loaded by polyglossia)

So code for your preamble :

\makeatletter
\newcommand{\before}{5.52pt}%Space before rule
\newcommand{\after}{10.52pt}% Space after rule
\renewcommand{\footnoterule}{%Redefine footnoterule
  \hrule width 3cm
  \kern \after}
% Change the space kept for rules+spaces around
\advance\skip\footins by \after
\advance\skip\footins by \before
% Not print the after space before the rule
\patchcmd{\@makecol}{\vskip \skip\footins}{\vskip \skip\footins\vskip-\after}{}{}
%load parafootskip
\usepackage[ruled,para]{manyfoot}
    % Not print the after space before the rule
\patchcmd{\MFL@joinrule}{\@tempskipa\skip#5}{\@tempskipa\skip#5\advance\@tempskipa by -\after}{}{}
\makeatother

But i think, indeed, that for next edition, you should look at eledmac.

  • tahnk you! Indeed, this code of yours works perfectly for rearranging the space before and after the footnote ruler. Do you have anything to suggest in order to compensate for the additional vertical space which is produced when I use the \newline command to separate one note of the footnote from the others? – orestis21 Oct 4 '14 at 15:58
  • no i have no idea... – Maïeul Oct 4 '14 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.