3

When I create 3D asymptote graphics, labels just don't work. When I copy the code from the question in Positioning Labels in Asymptote I get the exact same plot just without the "x". Everything works just find except the labels.

I am using Asymptote on Windows 7.

5

I have just recently set up Asymptote and Ghostscript on a new machine and run into exactly the problem you describe with 3D figures that used to work (affecting not just labels but other things, and causing an error when attempting to add axes3 with labels and other labels later on). After a bit of hunting around for a couple of days and not seeing anything about the problem I figured it must be somewhat new, and then your question pops up here.

I can't say what the bug is exactly that is causing this problem, but I can say that I fixed it this evening by installing an older version of Ghostscript (that my Asymptote code had worked under before). The one causing problems is GS 9.15 for 64-bit Windows. Try version 9.10 (here: http://www.ghostscript.com/GPL_Ghostscript_9.10.html) for whatever version of your operating system is appropriate (32- or 64-bit).

Ensure that you have everything specified properly in your config.asy file (can place this in the same directory as your working file - not sure if you can put it somewhere more general, but you probably can and I just haven't looked into the documentation enough). Mine looks like this with the default install path for GS:

import settings;
gs="C:\Program Files\gs\gs9.10\bin\gswin64c.exe";

Good luck.

  • 1
    That worked perfectly. Only had to install the old version of GS and everything was fine. Wouldn't have thought of that. – luffer Oct 2 '14 at 16:27
  • There's also a recent notification of exactly this problem (with the same solution) on the official website. – Charles Staats Nov 11 '14 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.