4

I have made an Ubuntu 14.04 fresh installation on a computer installing the following:

texmaker 4.1-1
texlive 2013
texlive-xetex 2013
texlive-luatex 2013
texlive-fonts-extra 2013
ttf-mscorefonts-installer

I set the Quick Build in TEXmaker to LuaLaTeX + View PDF

The MWE that I always got to work now does not work:

\documentclass{article}

%%%%%%%%%
% Fonts %
%%%%%%%%%

\RequirePackage[quiet]{fontspec}

\newfontfamily\blackfont[]{Arial Black}
\newfontfamily\thinfont[]{Lato Hairline}
\newfontfamily\headingfont[]{Impact}

\defaultfontfeatures{Mapping=tex-text}
\setmainfont[Mapping=tex-text, Color=textcolor]{Arial}


\begin{document}

This is bodyfont

\textit{This is bodyfont in italics}

\textbf{This is bodyfont in bold}

\headingfont{This is headingfont}

\thinfont{This is thinfont}

\blackfont{This is blackfont}

\end{document}

While it can find the fonts Lato Hairline and Impact, it cannot find Arial Black or Arial in italics or bold face... but all of them are included in ttf-mscorefonts-installer!!! What am I missing here?? It is weird since Lato Hairline is found but Arial Black isn't, and they are in the same place...

The errors/warnings that the MWE shows are the following:

enter image description here

  • 1
    strangely enough, xelatex seems to find them, so it isn't a problem with the fonts themselves, but maybe with lualatex... Can anyone reproduce the error? Does anyone know what can be missing? – DaniCee Oct 2 '14 at 19:39
  • Your MWE compiles fine with TeX Live 2014 from upstream - with both XeLaTeX and LuaLaTeX. Have you considered installing vanilla TeX Live? – cfr Oct 2 '14 at 20:38
  • I'd rather prefer to stick to the 2013 version that comes in the Ubuntu 14.04 repositories... I actually had no problem in the past working with this version, I don't know what happens now... maybe some extra package I should install or something?? I would consider vanilla TeX Live as a last resort... – DaniCee Oct 2 '14 at 22:41
  • 1
    I suspect it is due to the version of LuaTeX you have. I think there were some issues. Moreover, bugs etc. tend to have more of an impact for the newer TeX engines just because they are in a more radical phase of their development. I can't see how this can be a package issue. There might be a workaround, but I don't think it can be a missing package. Since LuaLaTeX finds other fonts fine, it would use just the same stuff to find Arial. The fact at XeTeX works further suggests this. I'm not sure, mind. But my suspicion is this is something which is fixed in later versions. – cfr Oct 2 '14 at 22:56
  • 1
    Note that it is very possible that an older version worked, too. Unless you know you used the same version in the past, that doesn't show the problem isn't in the version. You may now have a later version than you were using before, which may have introduced a bug which then gets fixed in later versions. (Version 2013 covers a year or so of updates so LuaTeX was almost certainly updated multiple times during that period. That is, version 2013 may not be the same version 2013 you previously had success with.) – cfr Oct 2 '14 at 22:59
8

So I did the following and the problem seems to be solved!!!

1- clean LuaLaTeX font cache (LuaTeX cannot find existing font):

 cd .texmf-var/luatex-cache/generic/fonts/otf/
 rm *

2- update Lua font name data base (Arch Linux: fontspec does not find system fonts):

luaotfload-tool --update

3- run:

sudo texhash

et voilà!

  • A question: If you set up a new system with the most recent version of ubuntum why not intstall texlive 2014? I also had some issues with the luatotfloader under tl2013, they are gone with the update to 2014 – MaxNoe Oct 3 '14 at 20:41
  • I prefer to stick to the ubuntu repositories whenever I can... just a preference – DaniCee Oct 4 '14 at 20:51
  • Usually a Good ideal, bitte not for tl. The updates are way to slow. Install tl 2014 and update with 'tlmgr' – MaxNoe Oct 4 '14 at 20:54
  • 1
    In some distribution this directory is located at $HOME/.texlive2013/texmf-var/luatex-cache/generic/fonts/otf – alfC Sep 7 '15 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.