2

I'm trying to use the insert frame breaks in LyX. [allowframebreaks] before/after the frame title and \framebreak don't seem to work. I'm indeed using those two as TeX codes.

Thanks

  • Please always state the version of the software you're using. Solutions might depend on it. In LyX 2.1.x beamer support is completely restructured compared to 2.0.x. Also, "doesn't seem to work" is very vague. Please be more descriptive and state what it does do (give an error? do the same thing without it?). Also, please give an .lyx file as an example. – scottkosty Oct 2 '14 at 21:15
3

In LyX 2.1.x, put the cursor just to the right of "Frame" and go to Insert > Frame Options. In the box, type "allowframebreaks".

To see an example of that in action, go to File > New From Template > beamer-conference-ornate-20min.lyx (note that the frame is too small for it to have an effect, I believe, but just add some more text).

  • Great! Thanks. Sorry about being vague and leaving open ends. – Ajax Oct 2 '14 at 21:44
  • I am indeed using LyX 2.1.1. Also, now my slides are numbered (appended to frame title). Is there any way I could remove this? – Ajax Oct 2 '14 at 21:48
  • @AjeyVenkataraman Sorry, I don't know. – scottkosty Oct 2 '14 at 21:52
  • @AjeyVenkataraman Then, you do not want allowframebreaks but some kind of overlays inside the frame like \only<1>{bla bla bla ...} \only<2>{more bla bla bla ...} etc. – Fran Oct 2 '14 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.