3

The bibliography style I am using (abbrvdin) uses for the author names all capital letters (like \textsc{}). When tracking in microtype is enabled it adds space between all those letters which doesn't look very good. I searched around and found one solution here.

\SetTracking{encoding=*, shape=sc}{50}

This unfortunatly does not work for me. The space between letters stays the same. What am I doing wrong?

Little more information, I am using: scrreprt, font libertine, bibstyle addrvdin and ngerman babel enabled.

Edit: I switched from libertine back to default font but the spacing didn't change to the value I have provided by SetTracking.

Edit 2: I have found a way around that issue

\microtypesetup{tracking=false}
\bibliography{lit}
\microtypesetup{tracking=true}

But this would also diable tracking in bib in non small capitals. So I would rather have a better solution.

EDIT: I am very sorry that it took me so long to add an example. But here it finally is:

\documentclass[
    12pt,
    paper=a4,
    titlepage=true,
    twoside=true,
    numbers=noenddot,
    parskip=half,
    headings=small,
    draft
]{scrreprt}

\usepackage[
    activate={true,nocompatibility},
    final,
    tracking=true,
    kerning=true,
    factor=1100,
    stretch=10,
    shrink=10
]{microtype}
\SetTracking{encoding=*, shape=sc}{200}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}    
\usepackage[ngerman]{babel}

\usepackage{libertine}
\usepackage[libertine,cmintegrals,cmbraces,vvarbb]{newtxmath}

\usepackage{babelbib}
\usepackage[nottoc]{tocbibind}
\bibliographystyle{abbrvdin}

\begin{document}
    \chapter{Something}
    Blah\dots\cite{carrier,kobayashi}

    \bibliography{literatur}
\end{document}

%%% CONTENT OF BBL FILE %%%
\begin{thebibliography}{1}

% this bibliography is generated by abbrvdin.bst [8.2] from 2005-12-21

\providecommand{\url}[1]{\texttt{#1}}
\expandafter\ifx\csname urlstyle\endcsname\relax
  \providecommand{\doi}[1]{doi: #1}\else
  \providecommand{\doi}{doi: \begingroup \urlstyle{rm}\Url}\fi

\bibitem[1]{carrier}
\textsc{Carrier}, B. :
\newblock \emph{File System Forensic Analysis}.
\newblock Addison Wesley Professional, 2005

\bibitem[2]{kobayashi}
\textsc{Kobayashi}, Y.  ; \textsc{Sommer}, C. :
\newblock On shortes disjoint paths in planar graphs.
\newblock {In: }\emph{Discrete Optimization}  (2010), Nr. 7, S. 234--245

\end{thebibliography}

As said in the initial question the SetTracking command does not solve the issue. I have to disable tracking completly to set it correct. Or else it looks like this: This is what it looks like

And this is what I think it should like when done right:

enter image description here EDIT 2:

Well I fixed the problem. Instead of

\SetTracking{encoding={*}, shape=sc}{40}

I used

\SetTracking{encoding={T1}, shape=sc}{40}

and it worked.

But, as in the comments pointed out, only small caps are kerned, everything else not.

  • @ap0, might be an idea if you also provide a bibliography. Or at least just the contents of this two item .bbl file (just past it in to the example, BibTeX does not seem relevant to this issue). – daleif Nov 6 '14 at 10:27
  • Your second screenshot doesn't seem to feature any tracking (aka letter-spacing) for words set in small-caps. Is that what you want? – Mico Nov 6 '14 at 10:29
  • @Mico this is correct. the second image has tracking set to false for the complete document. – ap0 Nov 6 '14 at 10:32
  • 1
    Where else is there any tracking? I do not see anything else but textsc – daleif Nov 6 '14 at 10:38
  • 1
    Then my question is, what exactly is it you want to be tracked/kerned? – daleif Nov 6 '14 at 11:12
4

The asterisk in

\SetTracking{encoding=*, shape=sc}{50}

is a placeholder that stands for "default". While for the \Declare... commands the translation of this placeholder takes place at the end of the preamble, for the \Set... commands, it takes places immediately. In your example, this results in the asterisk being translated to OT1, because inputenc -- which changes the default encoding to T1 -- is loaded two lines later.

Therefore, to have the asterisk expand to the default encoding that is actually used in the document, you should load inputenc before microtype.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.