2

The answer provided in this question does not work with classicthesis: Double line spacing

Specifically, using setspace and \doublespacing does not work. Using \linespread does but this introduces spacing in e.g. figure captions and tables too, which is not optimal.

Classicthesis can be found here: http://www.ctan.org/pkg/classicthesis

Since Classicthesis is used a lot for PhD theses, and a lot of these are required to be double spaced, I'm probably not the only one who's had this problem. Somebody had previously asked this question and it was (erroneously?) marked as a duplicate, linking back to the question above.

I'm not sure if I need to edit something in classicthesis.sty itself?

  • Hi and welcome, why shouldn't it work? It does very well. But keep in mind, classicthesis was designed for nice looking documents, even tought the implementations is a bit rough, the effort should be appreciated. Doublespacing and classicthesis should should contradict by common sense. – Johannes_B Oct 4 '14 at 14:34
  • \documentclass{report} \usepackage{classicthesis} \usepackage{setspace} \usepackage{blindtext} \begin{document} \doublespacing \chapter{matthew doublespace} \blindtext[4] \end{document} – Johannes_B Oct 4 '14 at 14:36
  • Ah, my sincere apologies. I misplaced the \doublespacing and had it before the \begin{document} instead of after it, which I realised after reading your example. It now works. I am completely agreed about not normally changing the very nicely designed defaults, but sadly double spacing is a requirement from my university that I have no say in. – Matthew Oct 4 '14 at 15:36
1

Is it a humanities thesis? Single-sided double-spaced not only looks awful but is a criminal waste of paper these days. I use

\setstretch{1.4} 

which has been green-lighted as perfectly acceptable.

  • 2
    Anyway,so-called ‘double-spacing’ doesn't mean setstretch{2}, but setstretch{1.6667} – Bernard Oct 4 '14 at 19:53
2

The above answer by Leadbetter worked for me, but only when I added

\usepackage{setspace} \setstretch{1.4}

to the .sty file. It did not work when I added it to the main tex file.

  • 4
    Welcome to TeX.SX! Although your solution surely works, it is always better to highlight that modifying original .sty files should be discouraged. As a solution, one can copy, rename those files before any modification and perform edits on the copies. – Claudio Fiandrino Mar 12 '15 at 14:30
0

Just another solution, since I run into the same error, which was caused by something different. Using the setspace usepackage is just fine, e.g.

\usepackage[onehalfspacing %doublespacing ]{setspace}

When using in combination with ClassisThesis the setspace usepackage must be set after the call of \usepackage{classicthesis}. Otherwise only page margins are changed, but not the line spacing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.