Before I start, this is probably closely related to Where do I place my own .sty or .cls files, to make them available to all my .tex files?, but I can't figure it out.

Previously I have had a file compiling and working fine. I am not sure what has changed, but all of a sudden today I have been receiving (Linux Mint 10.10)


(/usr/share/texmf-texlive/tex/latex/hyperref/pdfmark.def)) (./xy.sty

! I can't find file `xy'.

l.32 \input xy

I have tried to

sudo texhash

I have also tried just putting xy.sty in the directory, which didn't work either.

I tried the following:

kpsewhich -var-value TEXMFHOME


This folder does not exist, but it appears I have a hidden folder, i.e. /home/foo/.texmf-var

I tried to install the xy.sty file in /home/foo/.texmf-var/tex/latex If I call it xy.sty, it gives the same error message

If it is just called 'xy' I get

 TeX capacity exceeded, sorry [text input levels=15].

Basically - I don't know what I have done, what I can do to fix it, and if I am going to break anything else if I keep fiddling!

Edit: I should also note the following. Line 6 of the tex file is \usepackage[all]{xy}

While the error seems to refer to line 32?

  • 2
    kpsewhich xy.styis the command to find xy in your distribution. With OS X I have /usr/local/texlive/2011/texmf-dist/tex/generic/xypic/xy.styand I think xy.sty exists inside TL from a lot of years. A complete example will be very useful Jun 11, 2011 at 9:14
  • @Altermundus - this is just blank (I guess xy.sty really isn't found!). I don't have a /usr/local/texlive folder for what its worth
    – Qwirk
    Jun 11, 2011 at 9:21
  • /usr/local/texlive is only for OS X . This is different on Linux but what is your tex distribution ? Jun 11, 2011 at 9:28
  • Please use code blocks not quotation blocks for code and compiler messages. Inline code can be marked with backticks. Jun 11, 2011 at 9:43
  • how to install xy package in ubuntu in kile
    – user7359
    Aug 20, 2011 at 11:07

1 Answer 1


Besides xy.sty, you also need xy.tex. The error message belongs to line 32 of xy.sty, there's the command \input xy. This means xy.sty has been found but not the xy.tex file.

Just install the complete xypic package. On my system, with TeX Live 2011 pretest, the xypic directory contains 63 files.

  • @Stefan - thank you I have managed to get it working again. I wonder what happened??
    – Qwirk
    Jun 11, 2011 at 9:31
  • @Stefan I think xypic directory is a part of TL 2009 (and before) and it's not normal to install the complete xypic package Jun 11, 2011 at 9:31
  • And just to add one more comment - I just installed the texlive-pictures package, which has xy-pic in it, and let it do all the hard work for me - solved!
    – Qwirk
    Jun 11, 2011 at 9:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .