0

enter image description hereI have a problem with my latex code. I ve been using it for several years, but it is the first time that it happens. My problem is that when I compil the PDF, I have daggers almost everywhere mostly at the beginning of the section and at the end of the equation environment. And I have no idea how to get rid of them.

Do you know where could be the problem ?

Thanks

% debut d'un fichier latex standard
\documentclass[9pt,a4paper,twoside]{article} 

%%%Francisation
%\usepackage[T1]{fontenc}
%ecrire en fran?ais
\usepackage[francais,english]{babel}
%caracteres diacritiques
%\usepackage{lmodern}
%ecrire avec des accents sur mac
\usepackage[applemac]{inputenc}
%\usepackage[utf8]{inputenc}
%utilisation des guillemets
\usepackage[cyr]{aeguill}

%%%Packeages pour maths
%symbole math?matique
\usepackage{amsmath}   
\usepackage{amsthm}
%pr les ensembles math?matiques
\usepackage{amsfonts} 
%definis de nouveaux symboles comme l'ensemble vide
\usepackage{amssymb}
%police calligraphique
\usepackage{mathrsfs}
%package des unites
\usepackage[squaren,Gray]{SIunits}
%ecriture romaine 
\usepackage{modroman}
%numeration
\usepackage{enumerate}
\usepackage{listings} %code matlab
\usepackage{color} %red, green, blue, yellow, cyan, magenta, black, white
\definecolor{mygreen}{RGB}{28,172,0} % color values Red, Green, Blue
\definecolor{mylilas}{RGB}{170,55,241}
%package pour chimie
\usepackage{chemstyle}

%%%Packages images
%inclure des image   
\usepackage{graphics} 
%extension de graphics   
\usepackage[pdftex]{graphicx} 
\usepackage{graphicx}
\usepackage{float}
\usepackage{tikz}
\usepackage{pgfplots}
\usepackage{pdftricks}
\usepackage{subfig}
\usepackage{wrapfig}
\usepackage{listings}

closed as unclear what you're asking by ChrisS, Guido, Svend Tveskæg, doncherry, user31729 Oct 10 '14 at 10:56

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Daggers? Can you show a minimal example of your code, maybe the output and a log file? – Juri Robl Oct 6 '14 at 9:19
  • 4
    Welcome to TeX.SX! This is a thing never seen before, so please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will eventually be possible to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – yo' Oct 6 '14 at 9:30
  • 3
    @Astrinus No need to get hostile, it’s Bfrei’s first day here ... – doncherry Oct 6 '14 at 9:43
  • 3
    @Bfrei The first part of solving a problem is narrowing down the source. Producing a MWE has proven to be the best strategy for that. If it’s not the packages, the problem should still show up without any packages, right? (But to be honest, I’m not sure that will happen.) In order for us to help you – without just wildly guessing and wasting everybody’s time – it’s pretty much necessary that you create a MWE, starting with \documentclass{...} and ending with \end{document}. Then we can try to reproduce the problem and look for its source. Have a look at tohcz’s link, it’s really helpful. – doncherry Oct 6 '14 at 9:47
  • 4
    This should not have been closed. Please wait at least 24 hours after asking the OP for improvements to the question before voting to close. Also, if you downvote, please don't forget to revert the vote after the question is improved. – Martin Schröder Oct 6 '14 at 10:38
6

Probably you are using the wrong input encoding. In applemap.def, the \dag is produced by input code 160 (hex: 0xA0):

\DeclareInputText{160}{\dag}

But 0xA0 is "non-break space" in ISO-8859-1/latin1 or ISO-8859-15/latin9.

  • Check, that you use the correct input encoding option for package inputenc.
  • If the dagger is indeed coming from "non-break space", check your editing/editor, how they got inserted.

Package inputenx might help to find a better input encoding option. Also the editor might have options to set the encoding.

Not the answer you're looking for? Browse other questions tagged or ask your own question.