1

I am using TexShop (Version 3.42) to write Chemistry documents. I draw chemical structures in ChemDraw and import the .eps files.

Since I recently bought a new computer imported chemical structures are missing the capital letters. The structures are imported, but Ir becomes r, Me -> e and N disappears completely.

When compiling an older document that used to work just fine I get the same missing letters.

The only error I can find in my console is "/usr/texbin/dvips: Font Helvetica used in file images/xd262223.eps is not in the mapping file."

    \documentclass[11pt, oneside, english, ngerman]{scrreprt}       
\usepackage{geometry}                       
\geometry{a4paper}                          
\usepackage{graphicx}       
\usepackage{siunitx}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{amsmath}
\usepackage[section]{placeins}      \usepackage{chemmacros}
\usepackage[onehalfspacing]{setspace}
%
\usepackage{ragged2e}   
\usepackage{array}          
\usepackage[
natbib=true, backend=bibtex, style=chem-acs] {biblatex}
\addbibresource{latexlit.bib}
\usepackage{mhchem}
\usepackage{pxfonts}
\usepackage{chemnum}
\usepackage[journal=rsc, tracking=bpchem]{chemstyle}
\renewcommand{\thefootnote}{\alph{footnote}}

\title{Chemie \\
%
\vspace{20mm}%
\includegraphics*{images/logo}
    \vspace{20mm}}
\subtitle{Bericht}
\author{Xaver Dingeldoo}
\date{\today}                           
\publishers{Universit\"at Heidelberg}


\begin{document}
\maketitle
bliblablub



\end{document}  

Does anyone have an idea how I can fix this? Any help is appreciated.

Best wishes xd

5
  • 1
    Welcome to TeX SE! I'm afraid that example is not very useful as it will not allow anybody to reproduce the issue. However, the message concerning the non-mapped font is presumably key here. You either need to use a different font in the EPS file or configure TeX so that it knows what to use when that font is requested.
    – cfr
    Oct 7 '14 at 2:28
  • Yeah, that's what I thought. But people get always yelled at when not including one.. so I tried to stay safe with the MWE. Changing the font is not really an option, first it's a standard font of my MacOS and second the font is chosen by the journal style I need to use. I guess the question really is how I can I tell my TexShop that the fonts exist on my OS (I also checked in the font manager where they are all listed...)
    – user63825
    Oct 7 '14 at 2:47
  • 1
    Can you configure ChemDraw to embed the fonts in the eps? Oct 7 '14 at 10:54
  • @NicolaTalbot's suggestion will be by far the most straightforward if that's an option. Otherwise, it is more complex. Note that the issue has nothing to do with TeXShop - that is only an editor. You cannot directly use system fonts unless you compile with XeLaTeX, LuaLaTeX or ConTeXt, which I assume is not the case. So you really cannot use precisely that font at all simply except by embedding in ChemDraw. (I don't see why the fact that it is a standard OS font tells against a switch, but the requirements of the journal are a different matter.)
    – cfr
    Oct 7 '14 at 14:38
  • If ChemDraw can't embed the fonts, another possibility may be to use epstopdf, which I think will by default embed fonts (if not, use the --embed switch). Then use pdflatex rather than latex. Alternatively perhaps try eps2eps with -dEmbedAllFonts=true. Oct 7 '14 at 17:38
1

Ok,

so as an additional information I was using Latex. The option to embed the fonts in the eps file is apparently not offered by ChemDraw. The fact that Helvetica is a standard font does not speak against replacing it but it means that if one font of any should work it's this one.

When trying to use Nicola's suggestion with eps2eps it didn't work, however while looking through why I stumbled upon the option between Ghostscript and Apple Distiller. Switching from Ghostscript to AppleDistiller actually solved my problem. The console still tells me that the fonts are not in the mapping file but later it apparently can use them. The code look the following:

/usr/texbin/dvips: Font Helvetica used in file images/ps006pro.eps is not in the mapping file.
/usr/texbin/dvips: Font Helvetica used in file images/pyr.eps is not in the mapping file.
</usr/local/texlive/2014/texmf-dist/dvips/base/tex.pro>
</usr/local/texlive/2014/texmf-dist/dvips/psfrag/psfrag.pro>
</usr/local/texlive/2014/texmf-dist/fonts/enc/dvips/base/8r.enc>
</usr/local/texlive/2014/texmf-dist/dvips/base/texps.pro>
</usr/local/texlive/2014/texmf-dist/dvips/base/special.pro>
</usr/local/texlive/2014/texmf-dist/dvips/base/color.pro>. 
</usr/local/texlive/2014/texmf-dist/fonts/type1/urw/helvetic/uhvr8a.pfb>
</usr/local/texlive/2014/texmf-dist/fonts/type1/urw/palatino/uplri8a.pfb>
</usr/local/texlive/2014/texmf-dist/fonts/type1/urw/palatino/uplr8a.pfb>
</usr/local/texlive/2014/texmf-dist/fonts/type1/urw/helvetic/uhvb8a.pfb>[1
<./images/logo.eps>] [2] [3] [4<./images/ps006pro.eps><./images/pyr.eps>] 

It took me some time to answer this question because now Chemnum stopped numbering compounds, however this was due to a version change that required some new code.

Thanks for the help, and if anyone knows why the change to Apple Distiller helped I would be curious to know (even though the problem in my case is solved).

Best wishes xd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.