I'm putting together a paper for submission to the journal of quantitative finance, they provide a latex template:


See section 2: Style Guidelines/Latex template

They use their own document class and a number of sty files that are required.

I enclose a minimal version of their template file below (I have retained all parts that portain to the inclusion of eps files). If you compile this you will find that the figure with the eps files does not work. The Latex compiler comes back with "unknown graphics extension: .eps"

I have included all the .sty files that came with the template including graphicx.sty and subfigure.sty, but still it does not work.

When replicating the problem please include all the .sty files that can be found on the link above.

\usepackage{subfigure}% Support for small, `sub' figures and tables

\theoremstyle{plain}% Theorem-like structures




 \subsection{Submission of \LaTeX\ articles to the journal}\label{S1.2}

Authors who wish to incorporate Encapsulated PostScript artwork directly in their articles can do so by using
Tomas~Rokicki's {\tt EPSF} macros (which are supplied with the DVIPS PostScript driver). See Section~\ref{eps},
which also demonstrates how to treat landscape pages. Please remember to supply any additional figure macros you
use with your article in the preamble before \verb"\begin{document}". Authors should not attempt to use
implementation-specific \verb"\special"s directly.

\subsection{Illustrations (figures)}

The \textit{rQUF} class file will cope with most positioning of your illustrations and you should not normally need to use the optional placement specifiers of the \texttt{figure} environment. See `Instructions for Authors' in the journal's homepage on the Taylor \& Francis website  for how to submit artwork (note that requests to supply figures and tables separately from text are for the benefit of authors using Microsoft Word; authors using \LaTeX\ may include these at the appropriate locations in their PDF file). The original source files of any illustrations will be required when the final, revised version is submitted. Authors should ensure that their figures are suitable (in terms of lettering size, etc.) for the reductions they intend.

Figure captions should be below the figure itself, therefore the \verb"\caption" command should appear after the figure. For example, figure~\ref{sample-figure} with caption is produced using the following commands:

\subfigure[An example of an individual figure sub-caption.]{
\subfigure[A slightly shorter sub-caption.]{
\caption{\label{fig2} Example of a two-part figure with individual sub-captions showing that all lines of figure captions range left. The parts should be referred to in the text as `figure~\ref{sample-figure_part_a}' and `figure~\ref{sample-figure_part_b}'.

The control sequences \verb"\subfigure{}" and \verb"\includegraphics{}" require subfigure.sty and graphicx.sty.
The former is called in the preamble of the \texttt{rQUFguide.tex} file (in order to allow your choice of alternative if preferred)
and the latter by the \texttt{rQUF2e} class file; both are included with the \LaTeX\ style guide package for this journal for convenience.

To ensure that figures are correctly numbered automatically, the \verb"\label{}" command should be inserted just
after \verb"\caption{}".

  • Which TeX distribution do you use? If it's at all reasonably up-to-date, you shouldn't have to load the epsfig package at all; the graphicx package will invoke helper routines to handle an image file of format eps. If you use pdfLaTeX, you should be able to create pdf files directly, without going the old-fashioned route of first creating a dvi file, then a ps file, and finally a pdf file. Note also that the subfigure package is quite deprecated; you (and the folks at the Journal of Quantitative Finance too!!) should use either the subfig or the subcaption package.
    – Mico
    Oct 7 '14 at 11:54
  • I have Miktex 2.9
    – Bazman
    Oct 7 '14 at 12:12

It's possible that you are trying include .eps files and run with pdflatex.

This is impossible because pdflatex doesn't support inclusion of .eps files.

You have at least two options to solve this problem:

  • Follow the "compilation path" latex -> dvips -> ps2pdf (or if your document has Bibliography and/or Table of Contents latex -> bibtex (or biber if you use biblatex) -> latex -> latex -> dvips -> ps2pdf).

  • Use the package epstopdf (Add \usepackage{epstopdf} at the preamble) and run pdflatex with the option --shell-escape or --enable-write18 so

    pdflatex --enable-write18 <name>.tex


    pdflatex --shell-escape <name>


It seems that epstopdf script works in MiKTeX 2.9 with restricted \write18 (like makeindex) and the options --enable-write18 (or --shell-escape) are not necessary.

  • just adding \usepackage{epstopdf} was sufficient thanks!
    – Bazman
    Oct 7 '14 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.