9

I've been having issues using the flushend package to balance the last page's columns. I'm using it to balance bibliographies mainly. Flushend tends to (1) cut the last citation, (2) result in uneven spacing, and/or (3) repeat the citation at the end of the first column. This seems to be installation dependent as colleagues of mine do not run into these issues. I am using pdflatex in TexLive 2013 (full install) on Windows.

Here is an MWE with issues (1) and (2) appearing:

\documentclass[conference, 9pt]{IEEEtran}
\usepackage{flushend}
% \usepackage{balance}

\begin{document}
\nocite{*}
% \balance

\begin{thebibliography}{1}

\bibitem{test1}
J.~Doe and J.~Doe, ``This is a paper title, this is a paper title, this is a
  paper title, this is a paper title,'' in \emph{Some Proceedings}, Somewhere,
  Somewhere, 2014.

\bibitem{test2}
------, ``This is a paper title, this is a paper title, this is a paper title,
  this is a paper title,'' in \emph{Some Proceedings}, Somewhere, Somewhere,
  2014.

\bibitem{test3}
------, ``This is a paper title, this is a paper title, this is a paper title,
  this is a paper title,'' in \emph{Some Proceedings}, Somewhere, Somewhere,
  2014.

\bibitem{test4}
------, ``This is a paper title, this is a paper title, this is a paper title,
  this is a paper title,'' in \emph{Some Proceedings}, Somewhere, Somewhere,
  2014.

\bibitem{test5}
------, ``This is a paper title, this is a paper title, this is a paper title,
  this is a paper title,'' in \emph{Some Proceedings}, Somewhere, Somewhere,
  2014.

\bibitem{test6}
------, ``This is a paper title, this is a paper title, this is a paper title,
  this is a paper title,'' in \emph{Some Proceedings}, Somewhere, Somewhere,
  2014.

\end{thebibliography}

\end{document}

Here is how the output looks: flushend output

Here is the output using the balance package (not ideal but better): balance output

1

1 Answer 1

8

The bugfix flushed.sty, v3.1 2015/04/14, package version has some extra improvements.

Here is how the output looks now: flushend without options

To correct indent on the last line use package option keeplastbox: flushend with option keeplastbox

To suppress extra glue spread on the right column additionally use package option nospread:

flushend with options keeplastbox and nospread

To make right column shorter use \atColsEnd{\vskip10pt}:

flushend atColsEnd possitive

To make right column longer use \atColsEnd{\vskip-20pt}:

flushend atColsEnd negative

2
  • Welcome to TeX.SX! Perhaps you should post the example used for this screenshots
    – user31729
    Commented Apr 20, 2015 at 12:51
  • 1
    I get the error: Unknown option keeplastbox for package flushend If I try to do : \usepackage[keeplastbox]{flushend}
    – desmond13
    Commented Jul 8, 2016 at 9:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .