7

Every time I try to use the aforementioned keyboard shortcuts, LyX says "Command Disabled". How do I activate these shortcuts?

2
  • Note that "e" is used because it stands for "emphasize", which you can think of as an abstraction of "italicize".
    – scottkosty
    Oct 12, 2014 at 7:27
  • Incidentally, I believe that Ctrl-e and Ctrl+u are the default keystrokes bound to the font-emph and font-underline actions. So you could just use those shortcuts instead.
    – stochastic
    Jun 20, 2017 at 21:05

1 Answer 1

13

By default Ctrl+I may be set to "inset-toggle" which in regular use doesn't apply, while Ctrl+U should be set to "font-underline" (as is Alt+C U).

You are able to change the key binding sequences to suit your needs. Under Tools > Preferences > Editing > Shortcuts, activate the keys that you're interested in using as shortcut combinations. Specifically, find "font-ital" and "font-underline" under Font, Layouts and Textclasses:

enter image description here

If a bind is already used elsewhere, you can overwrite this to suit your personal needs.

2
  • Do you have any advice if the above method doesn't work? I'm trying to map Ctrl+1 to "layout Chapter" but get "Command disabled" even after removing the previous binding.
    – AnnanFay
    Jun 19, 2015 at 15:11
  • (I've managed to get it working with Alt+1, still curious why it didn't work with Ctrl)
    – AnnanFay
    Jun 19, 2015 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.