3

I use the following lines of codes to use biblatex. It all works, but the following: At every citation the citation looks like: [ 1] instead of [1]. This is true for all citations in the document. And I'm out of ideas how to solve this. Any help is appreciated. Thanks a lot in advance.

\usepackage[backend=bibtex,style=numeric-comp,sorting=none,doi=false,isbn=false,dateabbrev=false]{biblatex}
\addbibresource{tail/MyBib.bib}
\AtEveryBibitem{%
\clearlist{language}
\ifentrytype{misc}{}
{
    \clearfield{url}%
    \clearfield{urlday}%
        \clearfield{urlmonth}%
        \clearfield{urlyear}%
    }
}
\AtEveryCitekey{
    \clearfield{url}%
    \clearfield{urlday}%
        \clearfield{urlmonth}%
        \clearfield{urlyear}%
}

\renewbibmacro*{volume+number+eid}{%
  \printfield{volume}%
%  \setunit*{\adddot}% DELETED
  \setunit*{\addnbspace}% NEW (optional); there's also \addnbthinspace
  \printfield{number}%
  \setunit{\addcomma\space}%
  \printfield{eid}}
\DeclareFieldFormat[article]{number}{\mkbibparens{#1}}

\renewbibmacro{in:}{%
  \ifentrytype{article}{}{\printtext{\bibstring{in}\intitlepunct}}}
1
  • Welcome to TeX.SX! % at the end of \AtEveryBibem lines is not so important, because the items are evaluated when TeX is still not typesetting the entry; conversely, they will produce a space when the code in \AtEveryCitekey is performed.
    – egreg
    Oct 12, 2014 at 18:11

1 Answer 1

5

Use

\AtEveryCitekey{%  <--- You need the %

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .