I changed the parident and parskip of my document. But now there is a huge empty space after the sections. How can I reduce the space after a section?

Test test test test.

Test test test test.

Test test test test.

Test test test test.

1 Answer 1


You should probably use the parskip package rather than changing those values yourself. As for the spacing, you can use \titlespacing from the titlesec package to change the spacing. For example

\titlespacing\section{0pt}{12pt plus 4pt minus 2pt}{-6pt plus 2pt minus 2pt}

seems more or less reasonable for the spacing around the \section. Something similar would be needed for for \subsection and \subsubsection.

  • 6
    I can just add that, as mentioned in the parskip manual, the KOMA classes (and memoir, for that matter) have the features of that package builtin. Add e.g. parskip=full as an option to the documentclass. There are more choices, see the KOMA-script manual. Jun 14, 2011 at 10:38
  • @Torbjorn: Ah okay. Then in that case it's best to use the provided methods. I never use KOMA or memoir so I'm (more than) a little ignorant of them.
    – TH.
    Jun 14, 2011 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .