7

I am writing a lab manual and using \renewcommand{\familydefault}{\sfdefault} to set the font.

However, when using siunitx the\celsius unit does not change font. All other units (that I have so far used) use correct font, whereas \celsius seems to be cmr.

MWE

\documentclass{article}
\renewcommand{\familydefault}{\sfdefault}
\usepackage{siunitx}
\AtBeginDocument{\sisetup{math-rm=\mathsf, text-rm=\sffamily}}
\newcommand{\cc}{\cm\cubed}
\sisetup{range-phrase= --}
\begin{document}

\SI{250}{\cc} of solution were refluxed at \SI{73}{\celsius}.
A \SI{20}{\cc} aliquot of a solution of acetic acid was titrated against a standardised solution of NaOH (\SI{0.48}{\mole\per\deci\metre\cubed}. An average titre of \SI{15.3}{\cc} was required.  

A solution was distilled ensuring only the fraction boiling from \SIrange{56}{58}{\celsius} was collected.

The fraction boiling in the range \SIrange{56}{58}{\degreeCelsius} was collected.%just to see if \degreeCelsius produces a different output to \celsius

\end{document}

I tried the following solution Can I make siunitx commands use serif fonts like the rest of the math in beamer? as can be seen in the 4th line of the MWE but doesn't work.

I also tried this suggestion (adapted to my needs) in the comments by Qrrbrbirlbel in Change fonts for units in siunitx (effectively the same as above.)

Is this just a bug as the correct font is selected for my other units?

Or is this a standard for \celsius?

  • 1
    Until Joseph answers, a dirty trick is to use \let\mathrm\mathsf, \celsius is hardwired with a \mathrm – daleif Oct 14 '14 at 9:38
  • 1
    One can reset the definition with math-celsius={{}^{\circ}\kern-\scriptspace \mathsf{C}} – Ulrike Fischer Oct 14 '14 at 9:49
5

As Ulrike comments, a change to math-celsius seems needed here

\sisetup{math-celsius = {}^{\circ}\kern-\scriptspace C}

I think that looks better over all than the current definition: I'll probably change the standard setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.