4

I recently installed a commercial font called Monospace 821. The font came in ttf format and I installed it as usual in a Linux machine.

Problem is that when I use

\textbf{Bold}

the resulting text is not printed in bold. To get the bold I'm using the following workaround:

\newfontfamily\mybold{Monospace821BTBold}
\newcommand{\mytextbf}[1]{\mybold #1}

My question is: is this normal or is there a way to get the bold font automatically when using \textbf{...}?

\documentclass{article}
\usepackage{fontspec}
\setmainfont{Latin Modern Roman}
\newfontfamily\monobt{Monospace821BT}
\newfontfamily\mybold{Monospace821BTBold}
\newcommand{\mytextbf}[1]{\mybold #1}
\begin{document}

{\monobt \textbf{this is not bold}}

\mytextbf{this is bold}
\end{document}

The monospaced font is not used as tt font, I have another font set to \setmonofont{...} so I can't put Monospace 821 there.

4

If fontspec is unable to find the bold font associated to a medium series font, uou can use the normal options also with \newfontfamily:

\newfontfamily{\monobt}{Monospace821BT}[
  BoldFont={Monospace821BTBold}
]

and then

{\monobt\textbf{This is bold}}

should work.

Notice that the options should go before the font name with older versions of fontspec.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.