1

When using xrightarrow, I sometimes gets weird artifacts on the arrow: it looks like the arrow is somewhat "doubled" in the middle. But this only happens when zoomed out; when I zoom in very close, the artifact disappears. This happens with all the PS and PDF viewers that I've tried.

\documentclass{minimal}
\usepackage{amsmath}
\begin{document}
$\xrightarrow{\quad}$
\end{document}

Result (for SumatraPDF when compiled as a PDF, the results are similar if not identical for other viewers, PDF and PS alike):

arrow

Here I just put space to make the arrow longer, but it happens no matter what I put on the arrow. Is there a way around this issue, or an alternative to xrightarrow?

4
  • 1
    This is most likely due to pixel rounding errors in the PDF viewer. Note that the extension feature is made via overlaying two symbols.
    – daleif
    Oct 15, 2014 at 9:11
  • @daleif As I mentioned, this happens (to some extent) in all the PDF viewers that I've tried: sumatrapdf, adobe reader, ps_viewer (which reads PDFs despite the name). Oct 15, 2014 at 9:14
  • It also happens for PS viewers (sumatra, ghostscript...). Unless all these viewers have, by coincidence, the same bug, I think it's a problem with the way this arrow is produced, not a bug of the viewer. Oct 15, 2014 at 9:36
  • The \xrightarrow generates a set of minus signs (by \cleaders) followed by arrow. It is possible, that the arrow has different hinting data than the minus. These "hinting" are used for rasterizing at low screen resolution. Or the hinting algorithm does artifact itself when there are overlapping characters.
    – wipet
    Oct 16, 2014 at 7:38

1 Answer 1

0

Well, compare with this

\documentclass{article}
\usepackage{amsmath}
%\usepackage[T1]{fontenc}
\usepackage{anyfontsize}
\begin{document}

\fontsize{4cm}{4cm}\selectfont

$\xrightarrow{\quad}$
\end{document}

no vissible bug.

5
  • ...Yes there is still a bug, if you zoom out. i.imgur.com/J9YYFYH.png And anyway how is that a solution? It completely destroys the document. Oct 15, 2014 at 11:33
  • But it is still an artefact of the previewer. There is not much you can do about it other than try to change the font. It will not be detectable when printed on paper (because the resolution is much higher).
    – daleif
    Oct 15, 2014 at 12:06
  • Are you saying that all viewers have, for some reason, the exact same bug? Oct 15, 2014 at 12:08
  • 1
    Again it is not a bug! See tex.stackexchange.com/questions/132279/…
    – daleif
    Oct 15, 2014 at 12:08
  • Do you mean these artifacts are wanted behavior? Oct 15, 2014 at 16:15

Not the answer you're looking for? Browse other questions tagged .