While I was typesetting my document, the SyncTex function stopped to work. I use pdfLaTex. After having performed several search, I understand that I have to include the $synctexoption in the PdfLatex.exe that I get from

Edit > Preferences > Typesetting

Actually, the option is there. By further googling, I have understand that a .gz file shall be created, but if-fact it is not created. What is singular is that it always worked with the same document, and now is suddenly not working any longer. If may help, I work on the .tex document directly on Google Drive, and here is my preamble

 % Packages
\usepackage{longtable}   % To insert big tables over multiple pages
\usepackage{lmodern}  % Which fonts to use
\usepackage{textcomp} % Other text symbols
\usepackage{psfrag}  % Utilities for figures
\usepackage{bm}  % The package bm.sty allows you to write bold greek letters
\usepackage{bibentry} %This package allows one to be able to place bibliographic     entries anywhere in the text.
\usepackage[config, font={small}, labelfont={bf}]{caption}  % more flexibility for the caption
\usepackage{marvosym}   % Very amazing symbols!!!
\usepackage[table]{xcolor}  % this is used for colours


\DeclareGraphicsRule{.tif}{png}{.png}{`convert #1 `basename #1 .tif`.png} 

% ===== DASHED LINES ===========
% #1 is length of dash 
% #2 is length of gap between dashes 
%#3 is number of dashes
\dimen1=#2 \divide\dimen1 by 2
% line is 0.5ex above the baseline 
% and 0.4pt thick 
\count1=0 \loop% 
\advance\count1 by 1%

% ----- Useful Definitions ---------
% ===== END DASHED LINES ===========

I tried the following

  1. Move the .tex from Google drive and try to generate the pdf locally.
  2. Try to remove some packages and some part of the text and rebuild.
  3. I checked that in the path of my document there are not non-standard characters.

None of those solutions worked. What is strange it that it suddenly happened. Any hint?

closed as off-topic by egreg, user13907, user31729, percusse, Joseph Wright Nov 16 '14 at 9:28

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Update: I tried to install TexLive2014 but the problem does not seems to be solved. I tried to compile from the command line by issuing C:\...\Folder>pdflatex document_name.tex --synctex=1 but it does not generated any document_name.synctex.gz file. I also tried with --synctex=-1, but nothing happened. Any hint? – Ubaldo Tiberi Oct 16 '14 at 14:01
  • 4
    This question appears to be off-topic because it is about a non reproducible problem, apparently solved by a software update – egreg Nov 16 '14 at 8:37
  • As I wrote in my answer below and you correctly pointed out, the problem has been solved through a software update. I placed my answer since some other user may end up in the same problem. I just wanted to share my experience. Nevertheless, if the question is off-topic it can be removed of course - but I don't know if it is me that shall remove the question or you guys. – Ubaldo Tiberi Nov 17 '14 at 18:14
  • Don't worry! This kind of problems are quite difficult to reproduce, so once the “reason” for them is known, there's no point in attracting new answers (none appeared in a couple of weeks). If somebody comes up with a new insight, they can vote for reopening. – egreg Nov 17 '14 at 18:19

Just for you information, I was working with TexLive 2013 and now the problem has been solved by installing TexLive 2014. All I had to do was to be sure that the associated editor to open .tex files was TexWorks 2014 and not TexWorks2013. To verify which editor is used, it is enough to open TexWorks and go to

Help->Resources and Settings

And see what is reported there. If the editor is not the right one, it is enough to right click on any .tex file, select Open with... and then select the proper TexWorks.

Not the answer you're looking for? Browse other questions tagged or ask your own question.