3

As stated in the title, the use of \acuseall is giving me endless messages "LaTeX Warning: Label(s) may have changed. Rerun to get cross-references right". So I believe that something is wrong.

\documentclass{beamer}

\usepackage{arev}

\usepackage{acro}
\newcommand*{\acro}[3]{\DeclareAcronym{#1}{short=#2,long=#3}}
\acsetup{macros}
\acro{RAT}{RAT}{radio access technology}
\acro{CDMA}{CDMA}{code division multiple access}
\acro{OFDMA}{OFDMA}{orthogonal frequency division multiple access}
\acro{TDMA}{TDMA}{time division multiple access}
\acro{NOMA}{NOMA}{non-orthogonal multiple access}

\begin{document}

% Mark all acronyms as used
\acuseall

%%%%
\section{Spectrum Allocation\slash Trading}
\frame{%
    \frametitle{\insertsection: Traditional}%
    \framesubtitle{}%

    \begin{itemize}
        \item \alert{Dedicated licensed spectrum} 
        \item One operator, \ac{RAT}, etc.
        \item Orthogonality between different them, but 
        \item Shared (e.g., \ac{CDMA}) or orthogonal (e.g., \ac{OFDMA}) between users
    \end{itemize}
}

\frame{%
    \frametitle{Shared}%
    \framesubtitle{}%

    \begin{itemize}
        \item \alert{Shared licensed spectrum}
        \item At least two operators, \acp{RAT}, etc.
        \item Shared between them using time slots, i.e., \ac{TDMA}
        \item Shared (e.g., \ac{CDMA}), \ac{NOMA}, or orthogonal (e.g., \ac{OFDMA}) between users
    \end{itemize}
}
%%%%

%%%%
\frame{\printacronyms}
%%%%

\end{document}
  • 2
    I get no warning if I place \acuseall before \begin{document} – egreg Oct 15 '14 at 19:55
  • It works. I was lazy not testing that option. – cacamailg Oct 15 '14 at 20:02
3

The same behavior happens with the article class, so it seems a problem of timing in the processing of \acuseall.

Placing the command before \begin{document} seems to solve the issue. Probably the documentation should make this more clear.

2

This problem is resolved in version 1.6 (2015/02/26) of acro which has been sent to CTAN yesterday and should be available soon in TeX Live and MiKTeX.

\usepackage{acro}[2015/02/26]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.