3

When inserting a table in LyX, there's a space between the first and second rows, which I can get rid of by selecting the first row and turning off "bottom line", or selecting the second row and turning off "top line". However, if I try to do something similar to add space between the first and second columns of the table, removing the left line of the second column blanks out the line, and adding the left line to the first column adds in a second line.

Here's an example of what I've tried:

Imgur

  • This is because the "space" you see between the first and second rows is really the result of two LaTeX \hlines. It is just how LaTeX happens to handle it. LaTeX handles horizontal lines differently from vertical lines. – scottkosty Oct 19 '14 at 5:03
1

I'm assuming you need to add space between columns. You can do so by setting the width of column. In Lyx, highlight one of the entries in the column you wish to set (not just the text but the whole rectangular entry), right-click, then go to More... and Settings. In Column settings will be a width parameter. In the LaTeX output, changing that parameter produces widths (90pt and 151pt below):

\begin{tabular}{>{\raggedright}p{90pt}>{\raggedright}p{151pt}}
90 pt width & 150 pt width \\
\end{tabular} \vspace{-8bp}

Alternatively, just add blank spaces to the longest entry in your column.

  • Thank, but that doesn't produce blank space between the columns. – Matthew Cline Mar 2 '15 at 3:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.