26

I recently upgraded to OS X 10.10 Yosemite. To my great disappointment, TeXShop (3.43) built-in previews are blurred:enter image description here

I usually work on several pages documents and this kind of blur is very eye-tiring to me.

I tried (temporarily) switching to sans-serif fonts, but it doesn't get any better (nor does it by zooming under 200%). I also tried various combinations of font rendering options for Mac OS, again with no result at all.

Any suggestion (including other previewers which reportedly do not have this problem) is very welcome.

EDIT: Thanks everyone for reporting and pointing out possible solutions. As far as I understand the problem, it seems to be a combination of both Yosemite fonts rendering and TeXShop fonts processing. In my own case serif fonts are blurred everywhere, though the same fonts appear as more or less readable depending on the application (TeXShop pdf preview rendering is by far the worst). I summarize possible solutions, which I suggest to try in order:

  • Change TeX previewer/editor [I tried many in the last days, the best of which seems to be TeXWorks, though all of them are far from satisfying to me, at least for zoom lesser than 180-190%]
  • Turn off (uncheck) "Use LCD font smoothing when available" under 'System Preferences > General' [didn't work for most of users in the comments, yet slightly improved sans-serif fonts rendering in my TeXShop shell]
  • Change anti aliasing (font smoothing) options via command line in terminal (detailed instructions may be found here http://mac.software.com/tweaks/change-font-smoothing) [slightly improved general rendering of sans-serif fonts in my case]
  • As a last option, changing fonts might help a bit, especially for sans-serif ones
  • I've also updated to MacOSX "Yosemite", and when I create a test document using TeXshop 3.43, I get normal, i.e, non-fuzzy output. Can you tell us a bit more about your version of MacTeX? If would be helpful if you posted a specific test document that generates the problem behavior you're looking to fix. – Mico Oct 19 '14 at 13:07
  • @Mico: I have reinstalled MacTex 2014 today (hoping it would solve the problem) (tug.org/mactex/index.html). As for the test document, I'm having this blur issue on every file I've opened and they appear blurred even if I open them with Preview, so it seems to be a problem of the OS rather than of the editor. I tried to compile a new very basic document \documentclass{article} \begin{document} AAAA vhjkhv \end{document} but the result is the same. – AlephBeth Oct 19 '14 at 13:37
  • Does the same problem behavior occur if you use a different front-end program -- say, TeXworks -- to compile the MWE? – Mico Oct 19 '14 at 14:50
  • I just tried TeXworks and it worked quite fine: it is not as smooth as it was with TeXShop, but it's way better than with the actual TeXShop. Thank you for the suggestion! For the moment I will stick with TeXworks, but I'd like to find a solution for TeXShop too... – AlephBeth Oct 19 '14 at 15:23
  • 1
    I have the same issue, which only appeared after installing Yosemite. I think it might be an issue with how the programs render the typical TeX fonts on non-retina displays. (This is a conjecture, I am not an expert on this.) For example, using a dual-screen setup (external monitor + laptop screen) I have the following effect. The text in the preview screen (in TexShop for instance) is noticeably blurry when I view it on my external monitor. (As described in the original post.) This did not happen before the installation of the new OS. When I move the same preview window onto the retina laptop – user64764 Oct 21 '14 at 21:13
1

Turn off (uncheck) "Use LCD font smoothing when available" under 'System Preferences > General'. This worked for me.

  • Didn't work for me. – Anthony Quas Oct 21 '14 at 23:19
  • 1
    It didn't work for me. It was among the first things I did. I'm also puzzled that it must depend not just on the OS but on the particular way TeXShop is processing, as things appear fine in Adobe Reader, Preview ... or, in fact, in TeXWorks! – Ted Shifrin Oct 22 '14 at 3:11
  • 4
    Apparently this is an OS issue. See reddit.com/r/apple/comments/2joxlh/… – user11126 Oct 22 '14 at 11:33

protected by Joseph Wright Oct 24 '14 at 10:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.