3

I set up TexMaker a while ago, and configured it to use TexLive. I specified all of my paths correctly such that I could generate some nice looking PDFs for a while working on my thesis.

I tried to open my main file the other day (main.tex) when I received the curious error message:

enter image description here

After stating this, the file opens anyway but cannot compile. Using the regular QuickBuild takes too long (it doesn't even finish), so I used the command line instead. Using 'latex main.tex' I receive the following message: enter image description here

At this point I try and see from a command-line point of view whether the file 'main.tex' is there, so I run a simple 'dir' command:

enter image description here

Which simply shows me that the file is indeed there.

This worked for a while, but now doesn't do anything at all. My MWE would be quite long, however I downloaded the template from this source here.

If I try and compile a test file such as the following, it works fine:

\documentclass{article} \begin{document} This is a test document \end{document}

EDIT: I only have TexLive installed. If I try running pdflatex main.tex I have the following (rather lengthy) response, mainly about reference errors but since I can't use bibtex either I'm not sure what I can do:

enter image description here

Which continues to:

enter image description here

EDIT 2: I've noticed that if I remove /usepackage[version=3]{mhchem} the document compiles again (although without the features of the mhchem package).

  • Normally I use a lot of references also, so I'm forever using latex, bibtex, latex, latex. Not sure if that's the best way to go about it but it seems to have worked for me up until now. – TheJerseyChemist Oct 19 '14 at 16:23
  • My current version is Tex Live 2014, the one which was released in June of this year. – TheJerseyChemist Oct 19 '14 at 17:03
  • Just looking at TexMaker now, the screen which should be the pdf viewer has 'read-only' in the top left of the window. Could it be anything to do with this? – TheJerseyChemist Oct 19 '14 at 18:29
2

Since this question has come up a few times on the TeX.SE without answers, I thought I'd just post my experiences (as a beginner to LaTeX and its corresponding compilation).

It turns out that my issue 'main.tex not found' was purely coincidental to the problems that I was having. In fact, the reason why my file would not compile was due to the fact that I was trying to use mhchem markup in a subtitle heading, which it clearly didn't like.

So for other beginners with similar issues, the error messages are not always entirely helpful, and could indeed lead you down all sorts of false paths in trying to sort it out. It also doesn't help that various error messages come up, which, when you deal with the larger errors, completely disappear as non-issues. My advice is to look at the command line error message where it stops compiling, and ignore any potential error messages above this point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.