16

I have MacTex installed in my mac. It works fine before I upgrading to OS X Yosemite. After the upgrade, I can still compile the textual part, but the image part gives me this error: http://pastebin.com/0Bk6XraW

Mainly complain about dyld: Library not loaded: /usr/X11/lib/libXt.6.dylib?

Anybody has similar problem? How do you solve it? Thanks.

24

Actually, X11 is not erased but moved to /opt/X11.

So, the simplest solution would probably be to manually add the symbolic link from /usr/X11 to /opt/X11:

sudo ln -s /opt/X11 /usr/X11
4

Fixed after installing the latest XQuartz: http://xquartz.macosforge.org/landing/

The problem seems to be related to the fact that X11 was erased during the upgrade.

1

I had the exact same problem with another program that was working prior to upgrading to OS X Yosemite, and then returned the following error subsequent to upgrading:

dyld: Library not loaded: /usr/X11/lib/libX11.6.dylib
  Referenced from: /Users/grosbj/LANL/MCNP5/bin/mcnp5
  Reason: image not found
Trace/BPT trap: 5

fabianfuchs' suggestion fixed it!:

sudo ln -s /opt/X11 /usr/X11

Thanks!

  • 2
    Hi and welcome, this is more like a comment than a real answer to the question. Once you got enough reputation, you can leave comments yourself. Right now i think, your answer will be converted to a comment by a mod soon. – Johannes_B Mar 13 '15 at 15:57
1

Same problem after installing OSX Catalina ...

But now, you need to make a link like this:

sudo ln -s /opt/X11 /private/var/select/X11

(The link /usr/X11 points to /private/var/select/X11 and can't be modified.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.