4

I am running texworks on mac and pdflatex to generate pdf.

epstopdf used to run fine until i upgraded my mac to the new yosemite.

Now I have this problem -

[1{/usr/local/texlive/2011/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]sh: repstopdf: command not found

I tried to manually add

--enable-write18 

[1{/usr/local/texlive/2011/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]sh: epstopdf: command not found

I also installed texlive-fontutils through macports

Could anyone tell me how to solve this. I added \usepackage{epstopdf} to the preamble.

I can access both repstopdf and epstopdf on my terminal

I tried various solutions posted here tex-soln

UPDATE:

Taking the suggestion I installed texlive 2014 and removed the 2011 version:

I have the same problem:

[1{/opt/local/var/db/texmf/fonts/map/pdftex/updmap/pdftex.map}]sh: repstopdf: command not found
7
  • You might be best to reinstall the main TeXlive tree - the Yosemite upgrade copies everything in /usr/local apparently one file at a time, so possibly it has broken something in your set up. But I also notice that you are using TexLive 2011, so perhaps it's time for an upgrade to TexLive 2014? The best way to do that is to install the MacTeX package - 2G bytes, but worth it.
    – Thruston
    Oct 20, 2014 at 10:47
  • could i install texlive from macports ?
    – Pavan K
    Oct 20, 2014 at 11:55
  • i installed texlive and i still have the same problem [1{/opt/local/var/db/texmf/fonts/map/pdftex/updmap/pdftex.map}]sh: repstopdf: command not found
    – Pavan K
    Oct 20, 2014 at 12:48
  • Depending on how it's invoked, you could be running into an environment variable bug in Yosemite that breaks subprocess launching under some conditions. If repstopdf is not invoked with a full path, and/or the PATH environment variable isn't explicitly set in TeXworks, that's likely the source of your problems. More info here: code.google.com/p/mactlmgr/issues/detail?id=102 if anyone's interested. If you launch TeXworks from Terminal, that may work around the problem I described. Oct 20, 2014 at 23:50
  • I've described a potential workaround here: tex.stackexchange.com/questions/208181/… Oct 21, 2014 at 4:16

4 Answers 4

3

Launching TeXworks in the Terminal will work around an environment variable bug in OS X Yosemite. Assuming you have TeXworks installed in the /Applications folder, your command in Terminal would look like this:

/Applications/TeXworks.app/Contents/MacOS/TeXworks

Press return after entering the command, and TeXworks should launch. Correct functioning will depend on the caveats listed here in the more detailed description of the problem.

5

I ran this command, which re-instated the epstopdf binary:

sudo tlmgr  install epstopdf
0

I am a casual user, I found the same problem using Texstudio in Yosemite, it bugged me for so long, and I fixed it!

here is what you do: (based on this old post: https://stackoverflow.com/questions/829749/launch-mac-eclipse-with-environment-variables-set)

Create an empty text file called "texstudio.sh" in the Texstudio application bundle directory

/Applications/Texstudio.app/Contents/MacOS.

Open the texstudio.sh in a text editor an enter the following contents:

#!/bin/sh

export PATH=$PATH:/usr/texbin

logger "`dirname \"$0\"`/eclipse"

exec "`dirname \"$0\"`/eclipse" $@

In the Terminal set the executable flag of the shell script texstudio.sh, i.e.:

chmod +x /Applications/Texstudio.app/Contents/MacOS/texstudio.sh

Open the Texstudio.app Info.plist and change the value for the key Executable from texstudio to texstudio.sh.

MacOS X does not automatically detect that the Texstudio.app's Info.plist has changed. Therefore you need to force update the LaunchService database in the Terminal by using the lsregister command: /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -v -f /Applications/Texstudio.app

The next time you launch Texstudio.app from the Dock or from the Finder the environment variables should be set

0

I had this problem with texstudio and yosemite.

I fixed it like this. open ~/.bash_profile in a text editor

add the line

export PATH=$PATH:/usr/texbin

save the file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.