2

I am unable to number my bibliography using bibtex and a chicago style downloaded for this purpose. The numbering issue was present prior to the implementation of the chicago style add-in so I doubt that's the problem. I have looked at other examples, many of which appear to be one option taking precedent over another or a separate package making the modification. I can't seem to be able to figure this one out. please help. (Also, the brackets were not defaulting to round and I had to force the option, maybe that's a clue?)


\documentclass[11pt]{article}
\usepackage{graphics}
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{amsmath}   % improved mathematical formulas
\usepackage[round]{natbib}    % for citations (Endnote)
\usepackage{rotating}
\usepackage{booktabs}
\usepackage{amsmath}
\usepackage{verbatim}
\usepackage{multicol}

\setcounter{MaxMatrixCols}{10}
\DeclareMathOperator*{\plim}{plim}
\addtolength{\voffset}{-1cm} \addtolength{\hoffset}{-1cm}
\addtolength{\textwidth}{2.5cm} \addtolength{\textheight}{3cm}
\renewcommand{\baselinestretch}{1.5}

\begin{document}
\bibliographystyle{chicago}

\section{}
etc...
\section{}
text

\clearpage

\bibliography{terrvar}  % terrvar.bib is the library

% followed by tables and figures
\end{document}
  • 1
    I'm not sure how to interpret the objective "numbering the bibliography section". In the posted answer, I've assumed you wish to get a numbered sectioning header. If this assumption is incorrect, and if you want numeric citation callouts instead, you should load natbib with the option numbers. – Mico Oct 21 '14 at 20:42
1

Since you're using the article document class, you can get a numbered references section by adding the following instructions to the preamble:

\usepackage{etoolbox}
\patchcmd{\thebibliography}{\section*}{\section}{}{}

If you were using the report or book document class (or a document class that's based on either of these classes) you'd replace \section* with \chapter* and \section with \chapter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.