0

LyX seems to be having trouble accessing my .bib files.

Precursor info: I use a MacBook Pro with the latest versions of both LyX (2.1.2) and MacTeX. I use BibDesk for source management.

I recently updated to Yosemite and encountered this problem where LyX couldn't access any of my classes or styles. I followed the suggestions on the linked page to reconfigure LyX after opening it through Terminal instead of directly from the LyX menu.

That worked for those things (I can now access styles and classes and all of that), but I find that I can't insert citations. After I reconfigure and go to insert a Bibliography from the Lists menu, my .bib shows up as an available source, which I add. However, then when I go to insert a citation, the list of available citations is completely blank. If I go to click on the box representing the bibliography to add a source, I see my .bib filename still there. However, if I hit Rescan, the entire box becomes blank, suggesting that there are no .bib files to even access. I've tried reconfiguring again and the same process repeats: the .bib filename appears to be available, but it's really not upon attempting to insert a citation and rescanning the available .bib files.

The .bib file is there in the texmf/bibtex/bib directories both within my LyX Application Support folder and my user Library.

If I go to an old document that uses citations from that same .bib file, though, it can still produce a pdf with all the correct citations.

1

You have to run LyX from the terminal every time you use LyX. Not just for reconfigure. The LyX Mac developer is working on a workaround that will hopefully improve things until Apple fixes the bug.

  • That did/does the job. Thank you. And just to experiment, I ran it not through terminal and reconfigured again, and both problems reappeared. Then using terminal to both reconfigure and open for use repaired both. – lxgrdstdnt Oct 24 '14 at 2:42
0

I had a similar problem - the "Available Citations" box was blank when I tried to use a local .bib file, although for the example files which where there by default, it did work. The problem for me was that the path to the .bib file contained Hebrew script, and aparantly this caused a problem. When I changed the path to contain only English script, it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.