I'm trying to build a multi-file document with Rubber. In thesis.tex, I have:


and I have a file intro.tex.

It builds fine with pdflatex, but with rubber -d, I am getting the error:

IOError: [Errno 2] No such file or directory: 'intro.aux'

Curiously, this is only a problem if thesis.aux exists AND intro.aux does not exist. If I delete thesis.aux, the problem goes away. The problem also goes away if I touch intro.aux (even if it's an empty file). So perhaps I will just put rm thesis.aux into my Makefile.

But I am still curious if there is a way around this, or if it is a genuine bug in Rubber.

closed as too localized by Marco Daniel, egreg, percusse, Paulo Cereda, lockstep Jan 8 '12 at 12:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I tried a simple minimum working example with the same structure and it worked for me (Fedora 15, TeX Live 2011, rubber 1.1). It would be nice if you could come up with a MWE that actually reproduces the error. :) – Paulo Cereda Jan 7 '12 at 23:43
  • 1
    Addendum: It might be worth trying to clean all auxiliary files, with rubber --clean root. :) – Paulo Cereda Mar 23 '16 at 0:51

Browse other questions tagged or ask your own question.