Well, yesterday I posted here this question. I could solve that problem on my WS with Windows 7 and MikTeX 2.9 (64 bits) with the trick suggested by Mark Birtwistle. Nevertheless, today, working on my PC at the Institute (where I use MikTeX 2.9 on Windows XP) I have another unexpected and strange error.

First, from my previous question, the MWE where I corrected the previous errors is:

%%%%%%%%%%%%%%%%%%%%%%%% Acronyms    

 short = IFS , 
 long = Interacción fluido-sólido ,
 foreign = Fluid-Solid/Structure Interaction
 short = DFC , 
 long = Dinámica de fluidos computacional ,
 foreign = Computational Fluid Dynamics
 short = ADINA ,
 long  =  Automatic Dynamic Incremental Nonlinear Analysis ,
 class = software



Es un término genérico\sidenote{Del griego {\selectlanguage{greek} \textgreek{'arthr'ia}} \emph{arteria} y {\selectlanguage{greek} \textgreek{skl'hrwsic}} \emph{cicatriz, rigidez}.} que fue creado por Jean Georges Chrétien Frédéric Martin Lobstein.

Este capítulo tiene como objetivo proporcionar una descripción de las ecuaciones matemáticas que rigen y el algoritmo desarrollado para la modelación computacional \ac{ifs} del flujo sanguíneo y las geometrías del modelo utilizadas en el estudio.

La \ac{dfc} descompone la geometría en pequeñas celdas y por tanto tiene como objetivo resolver las ecuaciones que rigen para cada celda.

En la actualidad, varios paquetes de software como \ac{adina} proporcionan esta capacidad. Todos estos programas emplean el método de elementos finitos para resolver las ecuaciones de flujo. Este es el método preferido para resolver simulaciones \ac{ifs} de problemas estructurales, ya que es uno de los mejores métodos disponibles. 

\printacronyms[include-classes=software, name={Software}]    

I moved up the line where I load acro but as I had a clash with xcolor I moved it also. I put both before load babel. I know I can simplify {\selectlanguage{greek} \textgreek{ }} but I I haven't tried it yet.

Well, when I try to run the original file, the main.tex I have new errors:

! Package l3sort Error: Support package l3kernel too old.
See the l3sort package documentation for explanation.
Type H <return> for immediate help.
l.61 }
Please install an up to date version of l3kernel
using your TeX package manager or from CTAN.
Loading l3sort will abort!


! Package acro Error: Support package expl3 too old.
See the acro package documentation for explanation.
Type H <return> for immediate help.
l.50 }
You need to update your installation of the bundles 'l3kernel' and 'l3packages'
Loading acro will abort!

It was strange for me. I try to keep updated both installations. The first I did when I saw that was update the packages, that packages were from February 2014, not too old for me. I updated and later I refreshed FNBD and updated formats. All as an admin user.

I try to run it again but the errors remain. I searched for updates but there are not new updates for me today. This is a little bit tragic for me, because I have to finish everything About my thesis) in less than a week and I haven't biber on my other installation (it is 64 bits and I have not a cygwin.dll file) and I have to add references, what I do on this machine, but I can't with these errors.

Meanwhile this weekend I'll try to install linux and TeXLive2014 this weekend. Again if you want to see the original log file is here, and the real preamble is this. Thanks in advance.

closed as off-topic by egreg, Joseph Wright Jun 4 '16 at 22:08

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I think 'tragic' is a bit strong, even if it is your thesis. In any case, I don't recommend suing anybody ;). – cfr Oct 25 '14 at 1:37
  • I can't (try to) compile your code to reproduce the error because the acronym dfc is undefined. Please fix your code so that it is as close to compiling as you can manage. That way, just the real errors should be left when people try to run it. – cfr Oct 25 '14 at 1:39
  • 1
    @cfr Hahahaha I see, I misunderstood your comment, sorry. – Aradnix Oct 25 '14 at 2:36
  • 3
    If you have a miktex multiuser installation: don't run the update manager only in admin mode but also as user. And don't use the cygwin biber. Get the one in biberMSWIN.zip. – Ulrike Fischer Oct 25 '14 at 7:30
  • 2
    I'm voting to close this question as off-topic because it was solved by a software update – egreg Jun 4 '16 at 22:00

Browse other questions tagged or ask your own question.