3

When using todonotes with classicthesis, my notes appear on the wrong side. I have added the options \let\marginpar\oldmarginpar and \reversemarginpar to my preamble but when I use \reversemarginpar it also reverses the placement of the classicthesis fancy chapter numbers. Is there a way to reverse the side of todonotes only, without messing with the classicthesis formatting?

\documentclass{scrbook} 
\usepackage{classicthesis} 
\usepackage{todonotes}
%\let\marginpar\oldmarginpar
%\reversemarginpar
\usepackage{showframe}
\usepackage{blindtext}
\begin{document}
\chapter{a duck section}
\blindtext
\todo{a note} 
\end{document}
  • Seems like a bug, please inform the author of classicthesis. – Johannes_B Oct 30 '14 at 8:56
  • As this uses an scr class, you might be able to redefine \@todonotes@drawMarginNoteWithLine to use a note column instead. – Andrew Swann Oct 30 '14 at 8:57
1

This problem occurs because classicthesis is putting the chapter number in the marginpar, and so it is affected by \reversemarginpar. You can work around it by specifying the linedheaders option to classicthesis. The result is not quite the same, but you can always turn off that option when you no longer need todonotes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.