3

I'm running this MWE in MiKTeX 2.9 on Windows 7 Professional Operative System

\documentclass{article}
\usepackage{manfnt}
\usepackage[T1]{fontenc}

\begin{document}
\manerrarrow
\end{document}

The trouble is

  • If i run it with latex, pdflatex or lualatex i get a pixelated font created from manfnt.pk as is explained in the .log. Here a part of the read fonts:

    {
    C:/Program Files/LaTeX/MiKTeX 2.9/fonts/enc/dvips/cm-super/cm-super-t1.enc} <C:
    \Users\LuisP\AppData\Local\MiKTeX\2.9\fonts\pk\ljfour\public\misc\dpi600\manfnt.pk>
    <C:/Program Files/LaTeX/MiKTeX 2.9/fonts/type1/public/cm-super/sfrm1000.pfb>
    

    I have installed the packages cm-super (Adobe Type 1 fonts to replace Computer Modern fonts) and hoekwater (Fonts originally created in MetaFont, transformed to PostScript by Taco Hoekwater; includes logo, manfnt, rsfs, stmaryrd, wasy, wasy2, xipa).

    Although hoekwater includes manfnt.pfb, this is not read and the result is the ugly enter image description here

  • However if i run it with xelatex then there no problem and the result is the expected enter image description here

Is there someone capable to explain me this issue?

5
  • The code is fine. MiKTeX does not always update the font stuff correctly but I don't know much about it. I know you need to run updmap or the equivalent of doing that to update the map files. (XeTeX probably doesn't rely on the map files whereas pdfTeX does.)
    – cfr
    Oct 30, 2014 at 4:31
  • 1
    It is an error in the miktex package. The map-file is missing. I will make a bug report. In the mean time as a work-around download the map file mirrors.ctan.org/fonts/mflogo/ps-type1/hoekwater/mflogo.map (make sure that you get a map file and not a html-file!) but it in your document folder and add \pdfmapfile{+mflogo.map}. Oct 30, 2014 at 8:55
  • @UlrikeFischer it seems to be a frequent problem of MiKTeX. This problem appears also with the fonts of the package cmll and the solution is similar: Add Map cmll.map (cmll.map is already included in the cmll package) to updmap.cfg and run updmap.
    – skpblack
    Nov 3, 2014 at 16:17
  • Yes it happens that a map is missing. It is also a frequent problem that people don't make suitable bug reports. Nov 3, 2014 at 17:27
  • The miktex bug has been resolved. You should install the new mflogo-font package (and perhaps run updmap). Nov 21, 2014 at 8:40

1 Answer 1

3

The manfnt.map is missing from the MiKTeX distribution, hence the type 1 fonts are not mentioned in dvips.map and friends.

What you can do:

  1. Create manfnt.map, copying these two lines

    % Thomas Esser, 1998, public domain.
    manfnt manfnt <manfnt.pfb
    

Place in a LocalTeXMF (if you don't have one, create one and add it to the list of TeX roots via MiKTeX Settings, Roots tab. More precisely, put it in …\LocalTeXMF\fonts\map\dvips\manfnt.

  1. Go to C:\Users\Your_Username\AppData\Roaming\MiKTeX\2.9\miktex\config and open your personal updmap.cfg file. If you don't have one, create it, and insert these lines:

    # Manfnt
    
    Map manfnt.map
    

Save the file and refresh the FNBD. Never write in the distribution updmap.cfg, as it will be overwritten on updates.

  1. As administrator run from the command line: updmap --verbose. The switch wlil display what's happening.

It then should work:

enter image description here

1
  • Thanks, now it works, but i'd like that it was fixed from MiKTeX.
    – skpblack
    Oct 30, 2014 at 15:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .