2

I want to update tikz pgf package from 2.10 version to 3. I tried hard but couldn't make tlmgr to update it. There seems some proxy issue with tlmgr. I tried the solution provided here https://www.tug.org/pipermail/tex-live/2008-September/017529.html. But it doesn't work either!

export http_proxy='http://sct2si1:xxxxxxxxx@10.4.102.12:8080'
export ftp_proxy='http://sct2si1:xxxxxxxxx@10.4.102.12:8080'
export TL_DOWNLOAD_ARGS='-c'

There are no issues with installing tlmgr and opening its gui. The only trouble comes when I try to update any latex package using it. Here is an error message, when I tried to update self. I tried using different mirrors etc.. nothing works.

(running on Debian, switching to user mode!)
TLDownload::get_file: response error: 400 You can not proxy through the ftp (for ftp://tug.org/historic/systems/texlive/2013/tlnet-final/tlpkg/texlive.tlpdb.xz)
TLUtils::download_file: persistent connection ok, but download failed: ftp://tug.org/historic/systems/texlive/2013/tlnet-final/tlpkg/texlive.tlpdb.xz
TLUtils::download_file: retrying with wget.

Can any noble soul out there help me solve this problem?

  • Can't you update at all or is there a difficulty just in regard to pgf? Can you download the package and install it manually? Give some more details... – Keks Dose Nov 2 '14 at 12:59
  • tlmgr is not working at all on my system (Ubuntu 14.10). I solved the problem, anyway. I manually replaced the files in my system with the PGF3.0 .tex files. Its working file now. – Riyaz Nov 2 '14 at 13:41
  • OK, but "doesn't work" is not a helpful description. There may be many reasons. So edit your question and describe, how you installed tlmgr (did you succeed?) and what happens, if you, say, type tlmgr gui on the command line? – Keks Dose Nov 2 '14 at 13:45
  • see the updated question... – Riyaz Nov 3 '14 at 4:38
  • if your "current" tex installation comes from the linux install, you need to get incremental tex stuff using apt-get install, rather than tlmgr. i would have assumed that u14.10 would have the latest versions, but i don't currently use ubuntu-supplied tex, and since i've retired, i've no other machines to hand, to check. – wasteofspace Nov 3 '14 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.