I got an error on a new MiKTeX 2.9 win7 64-bit install while running the luaotfload tool.

luaotfload | Updating the font names database:
luaotfload | Font names database not found, generating new one.
      This can take several minutes; please be patient.
luaotfload | Updating the font names database:
The network name cannot be found.
Data: \\MiKTeX\]MPM[\fonts\opentype

The error is very cryptic and is very similar to

LuaTeX font database cannot be created in MiKTeX 2.9

Unfortunatly that topic was unanswered. However, I dug a little deeper and found the real cause. The $OPENTYPEFONTS path in MikTex is set to (among other things) '%R\fonts\opentype//'

Now I checked expanding this path using

kpsewhich --expand-path='%R'

and I get the same error. But if I use a small letter r

kpsewhich --expand-path="%r" 

it works perfectly fine.

How do I make kpsewhich case-insensitive or update the $OPENTYPEFONTS variable to have a small %r

  • I can't reproduce your error and I don't know why %R or %r should make a difference. But imho you should try to make a trace (see the miktex page) and then a miktex bug report with this new informations. Btw: You use different quotes in your kpsewhich calls. Nov 2 '14 at 12:19
  • @UlrikeFischer Thanks for you reply. The quotes are different only in the post. I have tried out all combinations. I will try your suggestion.
    – Arun
    Nov 3 '14 at 7:38

I came across the same problem and tried to implement your solution. Maybe someone knows a more elegant way, but it works for me now: In every affected Lua file in the directory tex/latex/luaotfload (for me: luaotfload-configuration.lua, luaotfload-database.lua, luaotfload-diagnostics.lua and luaotfload-parsers.lua) you have to replace the line

local kpseexpand_path = kpse.expand_path


local kpseexpand_path = function (p) return kpse.expand_path(string.gsub(kpse.expand_var(p), '%%R', '%%r')) end

It expands the variables $OPENTYPEFONTS and the others, but replaces %R by %r before that is expanded in turn. As far as I can tell from the MiKTeX source code, the appearance of %R in $OPENTYPEFONTS is hard-coded, so this is the only way I could find without recompiling MiKTeX...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.