12

Now, my version of TeXworks is 0.4.5r.1280 and I can't have the " character on the keyboard.

I have `` or '' instead. Why?

And It's the same with Alt+034. I'm very disappointed with that.

2
  • 2
    Check Format -> Smart Quotes: do you have this turned on? If so, TeXworks will deliberately turn " into `` or '' (depending on the settings).
    – Joseph Wright
    Nov 2 '14 at 11:02
  • 1
    For future reference: The reason TeXworks does this is because (all?) the various flavors of TeX use `` for a opening double quotation mark and '' for a closing double quotation mark. TeXworks is trying to be helpful by "autocorrecting" you on the fly. (See, for example, tex.stackexchange.com/questions/531/…)
    – jvriesem
    May 12 '16 at 20:59
17

TeXworks has a 'Smart Quotes' mode that deliberately changes " to either `` or '' using some context-dependent 'cleverness'. This is available as " is very rarely needed in a typesetting context. However, the setting is easy enough to turn off.

For a single file, you can go to Format -> Smart Quotes and choose None: this turns off the auto-conversion for the current file. To turn it off generally, go to Preferences (Edit menu on Windows/Linux, TeXworks menu on the Mac) and select 'None' under 'Smart Quotes' on the 'Edit' tab.

2
  • In text mode we are supposed to use two single quotes indeed --but-- in math mode it is supposed to be a double quote. So TeXworks' feature ought to be completed by a quick way of recovering the double quote symbol (faster than going into the menu back and forth all the time).
    – Arnaud
    Mar 8 '17 at 7:49
  • 2
    You can also type Ctrl-z (undo) after inserting the double quote in order to undo the automatic translation.
    – Jhor
    Jul 2 '19 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.