1

I'm using biblatex with bibtex as a backend and I am trying to understand the ordering of the citations in the bibliography. A MWE is as follows

\documentclass{article}

\begin{filecontents}{testbib.bib}
@article{geck:2015:on-kottwitz-conjecture,
    Author = {Geck, Meinolf},
    Journal = {J. Lie Theory},
    Number = 2,
    Pages = 395--429,
    Title = {On {K}ottwitz's conjecture for twisted involutions},
    Volume = 25,
    Year = 2015}

@article{geck-hiss:1996:CHEVIE,
    Author = {M. Geck and G. Hiss and F. L{\"u}beck and G. Malle and G. Pfeiffer},
    Journal = {Appl. Algebra Engrg. Comm. Comput.},
    Pages = 175--210,
    Title = {{\sf CHEVIE} -- {A} system for computing and processing generic character tables for finite groups of {L}ie type, {W}eyl groups and {H}ecke algebras},
    Volume = 7,
    Year = 1996}
\end{filecontents}

\usepackage[backend=bibtex,style=alphabetic,sorting=nyt,minnames=2]{biblatex}
\bibliography{testbib}

\begin{document}

See \cite{geck:2015:on-kottwitz-conjecture} and \cite{geck-hiss:1996:CHEVIE}.


\printbibliography
\end{document}

In the bibliography the citations then appear as

[GH+96] M. Geck, G. Hiss, et. al., CHEVIE - A system ...

[Gec15] M. Geck, On Kottwitz's conjecture ...

but this is wrong. Why is the multi-author document coming before the solo authored document? According to the biblatex manual (appendix C.1) the references should be first and foremost sorted by their author names as there is no presort or sortname specified.

Any insight into this would be greatly appreciated.

1

That is because you are inconsistent in your naming convention:

you use once

Geck, Meinolf

and once

M. Geck

Just stick to one naming and your references will be sorted as you want.

If you want to print only the first letter of the first name, just add

firstinits=true

to the options of biblatex.

  • One way to get rid of this kind of problem is to use strings. See http://www.bibtex.org/Format/ for instance if you're not familiar with this mechanism. – Clément Nov 3 '14 at 15:51
  • Thanks. I was using the firstinits=true option but hadn't realised that having different name formats was a problem. Now off to correct my .bib file. – Jay Taylor Nov 3 '14 at 16:30
  • Seriously consider using the strings. It really helps to design a consistent and usable bib file for cheap. – Clément Nov 4 '14 at 1:42
  • Thanks for insisting about using strings. I took another look at it and it's a great solution to this problem. Now all my authors are done with strings to maintain consistency. – Jay Taylor Nov 4 '14 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.