3

I'm trying to color all links by using this option:

\usepackage[colorlinks=true,allcolors=blue,breaklinks,draft=false]{hyperref}  

When compiling my .tex file, I get the error

Package keyval error: allcolors undefined

How do I rectify this.

closed as off-topic by egreg, Torbjørn T., Joseph Wright Feb 7 '15 at 23:00

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • From documentation: Note that all color names must be defined before use, following the normal system of the standard LaTeX color package. So are you loading some color package before? Or is it not necessary? – Sigur Nov 4 '14 at 10:39
  • Even after loading the color package, I get the same error. – kris Nov 4 '14 at 10:58
  • I get no error with that line using hyperref.sty 2012/11/06 v6.83m Hypertext links for LaTeX If you get an error please make state which version of hyperref you have – David Carlisle Nov 4 '14 at 11:10
  • @DavidCarlisle. Thanks for that hint, I have 2007/02/07 v6.75r installed. How can I update to the new version. Is it the same process as mentioned in CTAN website? – kris Nov 4 '14 at 11:53
  • 2
    I'm voting to close this question as off-topic because the problem is due to outdated software; the version of hyperref used doesn't support the option. – egreg Feb 7 '15 at 22:56

Browse other questions tagged or ask your own question.